Bug 1709840 - [Wayland] Desktop background shines through when playing fullscreen video
Summary: [Wayland] Desktop background shines through when playing fullscreen video
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ffwayland
TreeView+ depends on / blocked
 
Reported: 2019-05-14 12:00 UTC by Hans de Goede
Modified: 2019-09-10 08:10 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-10 08:10:57 UTC


Attachments (Terms of Use)

Description Hans de Goede 2019-05-14 12:00:45 UTC
When playing fullscreen videos from netflix, the desktop background; or underlying windows are subtly visible behind the video. It looks like the video overlay used for the fullscreen video is not entirely solid. I would say it has some alpha-transparency the video is almost solid, so 95 - 99%, but not entirely.

When using a background with high contrast and the video itself has little contrast (e.g. a mostly dark scene) then the background clearly shines through.

Interestingly enough this only happens when the firefox backend and the GNOME3 display protocol match, So using firefox with the X11 backend on GNOME on Xorg shows this problem, as does using firefox with the Wayland backend on GNOME as Wayland display server.

But running firefox with the X11 backend on top of GNOME as Wayland display server through Xwayland does not show this problem.

Comment 1 Hans de Goede 2019-05-14 12:03:21 UTC
Adding this to the ffwayland blocker bug since this will be a regression for people who are currently using firefox with the X11 backend on top of GNOME3 as Wayland display server (Fedora's current default setup).

Comment 2 Martin Stransky 2019-05-14 12:21:41 UTC
Looks like https://bugzilla.mozilla.org/show_bug.cgi?id=1516224

Comment 3 Martin Stransky 2019-05-14 12:29:45 UTC
Can you please:

- try a new profile
- try upstream binary (ff 66)
- try latest nightly (https://www.mozilla.org/en-US/firefox/channel/desktop)

Also do I understand correctly that:

Gnome/Xorg + Firefox = visible artifacts
Gnome/Wayland + Firefox X11 = non-visible artifacts
Gnome/Wayland + Firefox Wayland = non-visible artifacts

correct? Thanks.

Comment 4 Hans de Goede 2019-05-15 12:06:51 UTC
(In reply to Martin Stransky from comment #2)
> Looks like https://bugzilla.mozilla.org/show_bug.cgi?id=1516224

Yes that sounds exactly like what I'm seeing.

(In reply to Martin Stransky from comment #3)
> Gnome/Xorg + Firefox = visible artifacts
> Gnome/Wayland + Firefox X11 = non-visible artifacts
> Gnome/Wayland + Firefox Wayland = non-visible artifacts
> 
> correct? Thanks.

Almost, what I'm seeing is:

Gnome/Xorg + Firefox = visible artifacts
Gnome/Wayland + Firefox X11 = non-visible artifacts
Gnome/Wayland + Firefox Wayland = visible artifacts

The last combo is why I added this to the ffwayland blocker.

I'll go and run the tests you've requested now and I'll get back to you with the results.

Comment 5 Hans de Goede 2019-05-15 13:09:09 UTC
(In reply to Martin Stransky from comment #3)
> Can you please:
> 

All 3 below tests where done with firefox-wayland on top of a GNOME3 wayland session:

> - try a new profile

The problem still reproduces.

> - try upstream binary (ff 66)

The problem still reproduces.

> - try latest nightly (https://www.mozilla.org/en-US/firefox/channel/desktop)

The problem does not reproduce, when using the test video from moz bug 1516224 with MOZ_ENABLE_WAYLAND=1 :

https://www.youtube.com/watch?v=grEKMHGYyns

A white bar is shown above the video when it is fullscreen, so I think this does not count as fullscreen. I tried another video which did not have the whitebar above the fullscreen video problem; and there the problem also does not reproduce with the nightly.

Comment 6 Hans de Goede 2019-05-22 20:46:56 UTC
This is still happening with firefox 67, since the 68 nightly did not show the problem, I guess we need to wait for 68 hoping that 68 will fix this?

Comment 7 Hans de Goede 2019-07-11 13:16:17 UTC
I can confirm that firefox 68 fixes this, closing.

Comment 8 Hans de Goede 2019-07-15 14:45:07 UTC
Re-opening, sorry.

So it seems that at least with firefox 68 the "grey background" youtube video reproducer only works for the first 5 seconds and then the problem goes away for some reason, even when unfull-screening and re-fullscreeing. Shift+reload on the tab + re-fullscreen gives the problem for about 5 seconds again, which is why missed it when trying to reproduced it.

With netflix however the problem is permanently there, which is quite annoying.

Comment 9 Martin Stransky 2019-07-23 14:33:44 UTC
Yes, I can confirm that, on Fedora 30 / Firefox 68. But it happens for fullscreen video only. We may disable alpha blending for the fullscreen window.

Comment 10 Martin Stransky 2019-07-24 14:53:11 UTC
It's caused by this patch https://phabricator.services.mozilla.com/D12430

Comment 11 Martin Stransky 2019-07-24 16:14:50 UTC
Reported as https://bugzilla.mozilla.org/show_bug.cgi?id=1568569

Comment 12 Martin Stransky 2019-07-24 16:34:43 UTC
Added to firefox-68.0.1-2

Comment 13 Hans de Goede 2019-08-10 22:42:23 UTC
I can confirm that this is no longer a problem / that this is fixed in firefox-68.0.1-3.fc31.

So I guess this bug can be closed now.

Comment 14 Ben Cotton 2019-08-13 17:10:13 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.


Note You need to log in before you can comment on or make changes to this bug.