This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 170986 - ppc64 debuginfo rpms not generated
ppc64 debuginfo rpms not generated
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
5
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Bill Nottingham
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-10-16 22:24 EDT by Richard Henderson
Modified: 2014-03-16 22:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-08 09:54:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard Henderson 2005-10-16 22:24:29 EDT
Assigning this to glibc is wrong, since *none* of the ppc64 packages
have debuginfo rpms built.  But since Jakub had a hand in creating them
in the first place, perhaps he knows the right categorization.

Anyway, the net effect is that valid backtraces through glibc are hard
to come by, unless you happen to be on one of the code paths that have
eh unwind info associated.  Which isn't 100% coverage by far.
Comment 1 Jakub Jelinek 2005-10-17 03:24:59 EDT
ls -l dist/fc4/{glibc,gcc,binutils,coreutils,bash}/*/ppc64/*debuginfo*
-rw-r--r--    1 root     root      1323632 May 20 13:13
dist/fc4/bash/3.0-31/ppc64/bash-debuginfo-3.0-31.ppc64.rpm
-rw-r--r--    1 root     root      4761790 May 25 15:11
dist/fc4/binutils/2.15.94.0.2.2-2/ppc64/binutils-debuginfo-2.15.94.0.2.2-2.ppc64.rpm
-rw-r--r--    1 root     root      2645897 May 25 15:12
dist/fc4/coreutils/5.2.1-48/ppc64/coreutils-debuginfo-5.2.1-48.ppc64.rpm-rw-r--r--    1 root     root     57529743 May 20 13:19
dist/fc4/gcc/4.0.0-8/ppc64/gcc-debuginfo-4.0.0-8.ppc64.rpm
-rw-r--r--    1 root     root     20753528 May 30 17:17
dist/fc4/glibc/2.3.5-10/ppc64/glibc-debuginfo-2.3.5-10.ppc64.rpm

I certainly see them in FC4 (on porkchop and likewise in FC5).
And in rawhide too:
http://download.fedora.redhat.com/pub/fedora/linux/core/development/ppc64/debug/

So, are you not seeing them when you build new ppc64.rpm's, or are you just
missing them on ftp in fedora/linux/core/4/ppc/debug/
(where they clearly are missing, guess the compose scripts would need tweaking)?
Comment 2 Richard Henderson 2005-10-17 13:01:57 EDT
I meant the later, ftp in fedora/linux/core/4/ppc/debug/.  I didn't think to
look on our internal servers; I hadn't considered that we might be building
these and forgetting to copy them over.
Comment 3 Jakub Jelinek 2005-10-17 13:05:08 EDT
We aren't copying i386 debuginfo rpms either in the x86_64 composes, etc.
But the difference that matters here is that unlike x86_64 where there is
x86_64 distro and i386 distro, on ppc there is no ppc64 distro.

Anyway, reassigning to distribution, this is a releng issue.
Comment 4 Roland McGrath 2005-11-21 19:34:33 EST
Is this going to be fixed in FC5?
Should it be on a blocker list?
Comment 5 Bill Nottingham 2005-11-23 12:29:58 EST
 I can put it on the target list. Note that this is a mess, as the ppc/pp64 or
x86/x86_64 debuginfo RPMS will conflict with each other.
Comment 6 Jesse Keating 2006-08-07 14:34:42 EDT
Eeew, yes this is a major mess, especially since yum if asked to install a
package, will attempt to install all the arches available for said package.

yum install foo-debug 

will try to install

foo-debug.ppc
foo-debug.ppc64

This is particularly bad on say pure ppc systems.  Even non-pure ppc systems, if
you don't already have the 64bit version of an application, when you ask for a
debug package, by nature of bringing in both arches, it'll try to depsolve the
64bit package and pull even more 64bit stuff in.

I'm not sure there is a clean way to fix this, given the broken nature of how we
publish ppc(64). :/
Comment 7 Jesse Keating 2006-08-07 14:36:30 EDT
Hrm, I just looked at FC6 and we're doing exactly what I was afraid of, both ppc
and ppc64 debug info packages are in the ppc/debug/ dir.  We'll see if this
causes problems.

I'm not sure if we'd want to do anything in FC5 land for this.
Comment 8 Jesse Keating 2006-08-08 09:54:36 EDT
I'm not comfortable with changing anything for Fc5.  This is resolved in FC6.

Note You need to log in before you can comment on or make changes to this bug.