Bug 170987 - Incomplete Panel Transparency
Summary: Incomplete Panel Transparency
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-17 03:05 UTC by Craig Pemberton
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 19:33:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of transparent panel (27.20 KB, image/png)
2005-11-06 03:41 UTC, W. Michael Petullo
no flags Details
Illustration of incomplete transparency (21.36 KB, image/png)
2006-04-15 21:48 UTC, Jordan Nash
no flags Details

Description Craig Pemberton 2005-10-17 03:05:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Panel does a great job with transparency, but when are we going to get transparent  task names in the task bar, with options for changing the font color?  Also, the applet handles should be able to set to become partially visible on mouseover (ie not a block of grey, but some compromise).  Also, the icons in the system tray should match color / transparency of the rest of the panel.  These things are sore thumbs in what would otherwise be a gorgeous setup.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Look at bottom of screen.
2.
3.
  

Actual Results:  It wasn't entirely gorgeous.

Expected Results:  It was amazingly gorgeous.

Additional info:

Thanks!

Comment 1 W. Michael Petullo 2005-11-06 03:41:11 UTC
Created attachment 120766 [details]
Screenshot of transparent panel

Also, several applets are not transparency-friendly.  In the attached
screenshot, the volume and battery applets look very good.  However, the show
desktop applet is not as attractive.  The show desktop applet is completely
opaque.

Comment 2 W. Michael Petullo 2006-03-20 13:19:43 UTC
Can the owner of this bug set its Version to devel?  This seems to be applicable
to newer versions.

Comment 3 Jordan Nash 2006-04-15 21:44:14 UTC
In particular, the Nofification area (version 2.14.0) and left/right panel
boundaries do not properly support transparency.

Comment 4 Jordan Nash 2006-04-15 21:48:56 UTC
Created attachment 127789 [details]
Illustration of incomplete transparency

This picture illustrates the incomplete transparency of the notification area
and panel edges. The notification area has a box around it to show where it is.

Comment 5 Ray Strode [halfline] 2006-08-04 19:33:12 UTC
Hi guys,

The tasklist supports transparency now. Closing...

The notification area icons need to be fixed on an app by app basis (either
switch to GtkStatusIcon from libegg, or patch their libegg to support
transparency).  feel free to file individual bug reports as you run across
problem apps.






Note You need to log in before you can comment on or make changes to this bug.