Bug 171005 - rebuild problems on rawhide
rebuild problems on rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xalan-j2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Archit Shah
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-17 06:30 EDT by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-03 14:16:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of failed build (721.20 KB, text/plain)
2005-10-17 06:31 EDT, Karsten Hopp
no flags Details

  None (edit)
Description Karsten Hopp 2005-10-17 06:30:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050827 Fedora/1.1-0.2.8.deerpark.alpha2 Firefox/1.0+

Description of problem:
xalan-j2 fails to build on Rawhide: 
RPM build errors:
    File not found by glob: /var/tmp/xalan-j2-2.6.0-3jpp_3fc.src.rpm-root/usr/lib64/gcj/xalan-j2/xalan-j2-2.6.0.jar.*
    File not found by glob: /var/tmp/xalan-j2-2.6.0-3jpp_3fc.src.rpm-root/usr/lib64/gcj/xalan-j2/xsltc-2.6.0.jar.*

Version-Release number of selected component (if applicable):
xalan-j2-2.6.0-3jpp_3fc

How reproducible:
Always

Steps to Reproduce:
1.build xalan-j2 on a minimal system (mock)
2.
3.
  

Actual Results:  see attached log

Additional info:
Comment 1 Karsten Hopp 2005-10-17 06:31:40 EDT
Created attachment 120046 [details]
log of failed build
Comment 2 Gary Benson 2005-10-31 12:10:07 EST
Someone asked me about this on IRC on Friday.  There's a copy of
the main xalan jarfile embedded in xalan-j2-servlet.war, one of the
demo files.  The latest aot-compile-rpm finds this, and excludes the
main jarfile because the war has all of its classes and more.

Personally I'd just not package the war: it's only a demo file, and I
doubt anyone has ever used it.  If you don't want to do this then you
can pass "--exclude /usr/share/xalan-j2/xalan-j2-servlet.war" to the
aot-compile-rpm command line.
Comment 3 Archit Shah 2005-11-03 14:16:21 EST
fixed in xalan-j2-2.6.0-3jpp_4fc with the latter of gbenson's suggestions

Note You need to log in before you can comment on or make changes to this bug.