Bug 1710052 - [RHOS 15] Tempest test failure: test_list_extensions
Summary: [RHOS 15] Tempest test failure: test_list_extensions
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tempest
Version: 15.0 (Stein)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: beta
: 15.0 (Stein)
Assignee: Artom Lifshitz
QA Contact: nova-maint
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-14 19:49 UTC by Archit Modi
Modified: 2019-09-26 10:50 UTC (History)
16 users (show)

Fixed In Version: openstack-tempest-20.0.0-0.20190523153626.a955095.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:22:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
tempest-run.log (878.99 KB, application/x-xz)
2019-05-14 19:49 UTC, Archit Modi
no flags Details


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 659601 0 None None None 2019-07-22 06:24:26 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:22:23 UTC

Description Archit Modi 2019-05-14 19:49:14 UTC
Created attachment 1568633 [details]
tempest-run.log

Description of problem: Running the following tempest test after deploying RHOS 15 with mentioned topology gives errors:
tempest.api.compute.test_extensions.ExtensionsTest.test_list_extensions

core_puddle: RHOS_TRUNK-15.0-RHEL-8-20190509.n.1

How reproducible: always

Topology: 1 Controller, 2 Compute

Steps to Reproduce:
1. Deploy RHOS 15 with the above topology
2. Run the following tempest test: 
tempest.api.compute.test_extensions.ExtensionsTest.test_list_extensions

Actual results:
        
ft9.2: tempest.api.compute.test_extensions.ExtensionsTest.test_list_extensions[id-3bb27738-b759-4e0d-a5fa-37d7a6df07d1]testtools.testresult.real._StringException: pythonlogging:'': {{{
2019-05-11 21:33:41,966 215812 INFO     [tempest.lib.common.rest_client] Request (ExtensionsTest:test_list_extensions): 200 GET http://10.0.0.137:8774/v2.1/extensions 0.011s
2019-05-11 21:33:41,966 215812 DEBUG    [tempest.lib.common.rest_client] Request - Headers: {'Content-Type': 'application/json', 'Accept': 'application/json', 'X-OpenStack-Nova-API-Version': '2.1', 'X-Auth-Token': '<omitted>'}
        Body: None
    Response - Headers: {'date': 'Sat, 11 May 2019 21:33:41 GMT', 'server': 'Apache', 'content-length': '22700', 'openstack-api-version': 'compute 2.1', 'x-openstack-nova-api-version': '2.1', 'vary': 'OpenStack-API-Version,X-OpenStack-Nova-API-Version,Accept-Encoding', 'x-openstack-request-id': 'req-a273115c-bfde-44b7-9152-631cc5d8e669', 'x-compute-request-id': 'req-a273115c-bfde-44b7-9152-631cc5d8e669', 'connection': 'close', 'content-type': 'application/json', 'status': '200', 'content-location': 'http://10.0.0.137:8774/v2.1/extensions'}
        Body: b'{"extensions": [{"alias": "NMN", "description": "Multiple network support.", "links": [], "name": "Multinic", "namespace": "http://docs.openstack.org/compute/ext/fake_xml", "updated": "2014-12-03T00:00:00Z"}, {"alias": "OS-DCF", "description": "Disk Management Extension.", "links": [], "name": "DiskConfig", "namespace": "http://docs.openstack.org/compute/ext/fake_xml", "updated": "2014-12-03T00:00:00Z"}, {"alias": "OS-EXT-AZ", "description": "Extended Availability Zone support.", "links": [], "name": "ExtendedAvailabilityZone", "namespace": "http://docs.openstack.org/compute/ext/fake_xml", "updated": "2014-12-03T00:00:00Z"}, {"alias": "OS-EXT-IMG-SIZE", "description": "Adds image size to image listings.", "links": [], "name": "ImageSize", "namespace": "http://docs.openstack.org/compute/ext/fake_xml", "updated": "2014-12-03T00:00:00Z"}, {"alias": "OS-EXT-IPS", "description": "Adds type parameter to the ip list.", "links": [], "name": "ExtendedIps", "namespace": "http://docs.openstack.org/compute/ext/fake_xml", "updated": "2014-12-03T00:00:00Z"}, {"alias": "OS-EXT-IPS-MAC", "description": "Adds mac address parameter to the ip list.", "links": [], "name": "ExtendedIpsMac", "namespace": "http://docs.openstack.org/compute/ext/fake_xml", "updated": "2014-12-03T00:00:00Z"}, {"alias": "OS-EXT-SRV-ATTR", "description": "Extended Server Attributes support.", "links": [], "name": "ExtendedServerAttributes", "namespace": "http://docs.openstack.org/compute/ext/fake_xml", "updated": "2014-12-03T00:00:00Z"}, {"alias": "OS-EXT-STS", "description": "Extended Status support.", "links": [], "name": "ExtendedStatus", "namespace": "http://docs.openstack.org/compute/ext/fake_xml", "updated": "2014-12-03T00:00:00Z"}, {"alias": "OS-FLV-DISABLED", "description": "Support to show the disabled status of a flavor.", "links": [], "name": "FlavorDisabled", "namespace": "http://docs.openstack.org/compute/ext/fake_xml", "updated": "2014-12-03T00:00:00Z"}, {"alias": "OS-FLV-EXT-DATA", "description": "Provide additional data for flavors.", "links": [], "name": "FlavorExtraData", "namespace": "http://docs.openstack.org/compute/ext/fake_xml", "updated": "2014-12-03T00:00:00Z"}, {"alias": "OS-SCH-HNT", "description": "Pass arbitrary key/value pairs to the scheduler.", "links": [], "name": "SchedulerHints", "namespace": "http://docs.openstack.org/compute/ext/fake_xml", "updated": "2014-12-03T00:00:00Z"}, {"alias": "OS-SRV-USG", "description": "Adds launched_at and terminated_at on Servers.", "links": [], "name": "ServerUsage", "namespace": "http://docs.openstack.org/compute/ext/fake_xml", "updated": "2014-12-03T00:00:00Z"}, {"alias": "os-access-ips", "description": "Access IPs support.", "links": [], "name": "AccessIPs", "namespace": "http://docs.openstack.org/compute/ext/fake_xml", "updated": "2014-12-03T00:00:00Z"}, {"alias": "os-admin-actions", "description": "Enable admin-only server actions\\n\\n    Actions include: resetNetwork, injectNetworkInfo, os-resetState\\n    ", "links": [], "name": "AdminActions", "namespace": "http://docs.openstack.org/compute/ext/fake_xml", "updated": "2014-12-03T00:00:00Z"}, {"alias": "os-admin-password", "description": "Admin password management support.", "links": [], "name": "AdminPassword", "namespace": "http://docs.openstack.org/compute/ext/fake_xml", "updated": "2014-12-03T00:00:00Z"}, {"alias": "os-agents", "description": "Agents support.", "links": [], "name": "Agents", "namespace": "http://docs.openstack.org/compute/ext/fake_xml", "updated": "2014-12-03T00:00:00Z"}, {"alias": "os-aggregates", "description": "Admin-only aggregate administration.", "links": [], "name": "Aggregates", "namespace": "http://docs.openstack.org/compute/ext/fake_xml", "updated": "2014-12-03T00:00:00Z"}, {"alias": "os-assisted-volume-snapshots", "description": "Assisted volume snapshots.", "links": [], "name": "AssistedVolumeSnapshots", "namespace": "http://docs.openstack.org/compute/ext/fake_xml", "updated": "2014-12-03T00:00:00Z"}, {"alias": "os-attach-interfaces", "description": "Attach interface support.", "links": [], "name": "AttachI
2019-05-11 21:33:41,975 215812 DEBUG    [tempest.api.compute.test_extensions] Nova extensions: NMN,OS-DCF,OS-EXT-AZ,OS-EXT-IMG-SIZE,OS-EXT-IPS,OS-EXT-IPS-MAC,OS-EXT-SRV-ATTR,OS-EXT-STS,OS-FLV-DISABLED,OS-FLV-EXT-DATA,OS-SCH-HNT,OS-SRV-USG,os-access-ips,os-admin-actions,os-admin-password,os-agents,os-aggregates,os-assisted-volume-snapshots,os-attach-interfaces,os-availability-zone,os-baremetal-ext-status,os-baremetal-nodes,os-block-device-mapping,os-block-device-mapping-v2-boot,os-cell-capacities,os-cells,os-certificates,os-cloudpipe,os-cloudpipe-update,os-config-drive,os-console-auth-tokens,os-console-output,os-consoles,os-create-backup,os-create-server-ext,os-deferred-delete,os-evacuate,os-extended-evacuate-find-host,os-extended-floating-ips,os-extended-hypervisors,os-extended-networks,os-extended-quotas,os-extended-rescue-with-image,os-extended-services,os-extended-services-delete,os-extended-status,os-extended-volumes,os-fixed-ips,os-flavor-access,os-flavor-extra-specs,os-flavor-manage,os-flavor-rxtx,os-flavor-swap,os-floating-ip-dns,os-floating-ip-pools,os-floating-ips,os-floating-ips-bulk,os-fping,os-hide-server-addresses,os-hosts,os-hypervisor-status,os-hypervisors,os-instance-actions,os-instance_usage_audit_log,os-keypairs,os-lock-server,os-migrate-server,os-migrations,os-multiple-create,os-networks,os-networks-associate,os-pause-server,os-personality,os-preserve-ephemeral-rebuild,os-quota-class-sets,os-quota-sets,os-rescue,os-security-group-default-rules,os-security-groups,os-server-diagnostics,os-server-external-events,os-server-group-quotas,os-server-groups,os-server-list-multi-status,os-server-password,os-server-sort-keys,os-server-start-stop,os-services,os-shelve,os-simple-tenant-usage,os-suspend-server,os-tenant-networks,os-used-limits,os-used-limits-for-admin,os-user-data,os-user-quotas,os-virtual-interfaces,os-volume-attachment-update,os-volumes
}}}

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/tempest/api/compute/test_extensions.py", line 46, in test_list_extensions
    self.assertIn(ext, extension_list)
  File "/usr/lib/python3.6/site-packages/testtools/testcase.py", line 417, in assertIn
    self.assertThat(haystack, Contains(needle), message)
  File "/usr/lib/python3.6/site-packages/testtools/testcase.py", line 498, in assertThat
    raise mismatch_error
testtools.matchers._impl.MismatchError: 'NMN' not in <map object at 0x7f268b481f98>

Expected results:
Test passed

Additional info:

Comment 3 Artom Lifshitz 2019-05-16 19:34:24 UTC
Given that API extensions are deprecated [1] I'm questioning the value of running the test_list_extensions test in downstream CI. We should not be setting [compute_feature_enabled]/api_extensions in tempest.conf.

[1] https://developer.openstack.org/api-ref/compute/?expanded=list-extensions-detail#extensions-extensions-deprecated

Comment 4 Chandan Kumar 2019-05-22 14:33:25 UTC
https://review.opendev.org/#/c/659601/ fixes the test mismatch issue on RHEL-8 RHOS-15, Can we reopen the bug?  We will remove the above part?

Comment 5 Artom Lifshitz 2019-05-24 17:56:09 UTC
(In reply to Chandan Kumar from comment #4)
> https://review.opendev.org/#/c/659601/ fixes the test mismatch issue on
> RHEL-8 RHOS-15, Can we reopen the bug?  We will remove the above part?

I'm still not convinced about the value of running those extensions tests, but since the work to fix it has already been done, I don't see why we shouldn't track it properly. Do I just close this as UPSTREAM then, or we have an actual OSP build NVR to set?

Comment 6 Chandan Kumar 2019-05-29 08:53:55 UTC
Hello Artom,

We can add the following nvr https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=901681 -> openstack-tempest-20.0.0-0.20190523153626.a955095.el8ost for this bug.
One more question, [compute_feature_enabled]/api_extensions is setted by python-tempestconf tool, we can remove it from there. From which release it is being deprecated? (We can open a python-tempestconf bug for the same)


Thanks,

Chandan Kumar

Comment 7 Artom Lifshitz 2019-05-29 12:55:41 UTC
> One more question, [compute_feature_enabled]/api_extensions is setted by
> python-tempestconf tool, we can remove it from there. From which release it
> is being deprecated? (We can open a python-tempestconf bug for the same)

In Tempest the deprecation is from commit 5078e8b87de957f2aa0dcc6973a29fa0284f8d80 [1] from the end of 2016. In Nova it's from 75280e582e6d607b38bc2af9f51f80fd5135453c [2] from the beginning of 2016. Not sure what release that corresponds to, but I think we can safely remove extensions from python_tempestconf.

[1] https://review.opendev.org/#/c/371612/
[2] https://review.opendev.org/#/c/310399/

Comment 8 Chandan Kumar 2019-05-29 13:59:52 UTC
Thanks Artom,

Added the story here https://storyboard.openstack.org/#!/story/2005794, we are safe to remove it.

Comment 11 Martin Kopec 2019-07-22 06:24:27 UTC
The fix is available in the Fixed in version package.

Comment 13 errata-xmlrpc 2019-09-21 11:22:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.