Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1710172 - [cloud] Could not disable machinehealthcheck using FeatureGates
Summary: [cloud] Could not disable machinehealthcheck using FeatureGates
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Vikas Choudhary
QA Contact: sunzhaohua
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-15 03:26 UTC by sunzhaohua
Modified: 2019-07-26 15:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-26 15:06:26 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description sunzhaohua 2019-05-15 03:26:42 UTC
Description of problem:
Cloudn't disable machinehealthcheck by setting FeatureGates' spec value to {} according to the doc https://docs.openshift.com/container-platform/4.1/nodes/clusters/nodes-cluster-disabling-features.html

Version-Release number of selected component (if applicable):
$ oc get clusterversion
NAME      VERSION      AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.1.0-rc.3   True        False         44h     Cluster version is 4.1.0-rc.3

How reproducible:
Always

Steps to Reproduce:
1. Obtain the FeatureGate
$ oc get featuregate
NAME          AGE
cluster       45h
machine-api   18h

2. Edit FeatureGate machine-api setting the spec value to {}  to disable the Technology Preview features
3. Check machinehealthcheck feature removed or not

Actual results:
Couldn't disable machinehealthcheck by setting the FeatureGate's spec value to {}

$ oc get pod
NAME                                           READY   STATUS    RESTARTS   AGE
cluster-autoscaler-default-f8bf5fdc6-b9wvf     1/1     Running   0          18h
cluster-autoscaler-operator-7556b9fd94-cf5pc   1/1     Running   0          18h
machine-api-controllers-5c9fd97c6f-vdrx7       4/4     Running   0          18h
machine-api-operator-6755b6fb58-ks66t          1/1     Running   0          18h

$ oc logs -f machine-api-controllers-5c9fd97c6f-vdrx7 -c machine-healthcheck-controller
I0515 02:59:25.944646       1 machinehealthcheck_controller.go:112] Node ip-10-0-147-178.us-east-2.compute.internal is annotated with machine openshift-machine-api/zhsun4-cl6qv-worker-us-east-2b-rrckp
I0515 02:59:25.944727       1 machinehealthcheck_controller.go:169] Initialising remediation logic for machine zhsun4-cl6qv-worker-us-east-2b-rrckp
I0515 02:59:25.945042       1 machinehealthcheck_controller.go:273] ConfigMap node-unhealthy-conditions not found under the namespace openshift-machine-api, fallback to default values: items:
- name: Ready
  status: Unknown
  timeout: 300s
- name: Ready
  status: "False"
  timeout: 300s
I0515 02:59:25.945400       1 machinehealthcheck_controller.go:251] No remediaton action was taken. Machine zhsun4-cl6qv-worker-us-east-2b-rrckp with node ip-10-0-147-178.us-east-2.compute.internal is healthy

Expected results:
Could disable machinehealthcheck by setting the FeatureGate's spec value to {}

Additional info:

Comment 2 Andrew Beekhof 2019-06-13 12:39:26 UTC
This was a doc bug, disabling feature gates is not possible and the page has been removed


Note You need to log in before you can comment on or make changes to this bug.