Bug 1710235 - 'ipa-cacert-manage renew' does not update 'cn=cacert,cn=ipa,cn=etc,$SUFFIX'
Summary: 'ipa-cacert-manage renew' does not update 'cn=cacert,cn=ipa,cn=etc,$SUFFIX'
Keywords:
Status: CLOSED DUPLICATE of bug 1544470
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.7
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: ipa-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-15 07:22 UTC by Thorsten Scherf
Modified: 2019-05-16 09:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-15 11:38:05 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Thorsten Scherf 2019-05-15 07:22:33 UTC
Description of problem:
Setup: Externally signed IdM CA certificate. The external CA certificate is renewed at some point, so that the IdM CA certificate also needs to be renewed:

# ipa-cacert-manage renew --external-ca
# ipa-cacert-manage renew --external-cert-file=/root/ipa-new.crt --external-cert-file=/root/ipa-ca-new.crt

Certmonger shows that the 'caSigningCert' has been renewed successfully. Running the following 'certmonger' command still writes the old IdM CA certificate into '/tmp/foo.crt' though:

# ipa-getcert request -f /tmp/foo.pem -k /tmp/foo.key -F /tmp/foo.crt

Reason for this is that the LDAP entry 'cn=cacert,cn=ipa,cn=etc,$SUFFIX' is not updated with the new IdM CA certificate. A manual update of this entry resolves the problem.

Version-Release number of selected component (if applicable):
ipa-server-4.6.4-10.el7.x86_64
certmonger-0.78.4-10.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. see above
2.
3.

Actual results:
Executing 'ipa-getcert request' uses the old IdM CA certificate.

Expected results:
Executing 'ipa-getcert request' should use the renewed IdM CA certificate.



Additional info:

Comment 2 Florence Blanc-Renaud 2019-05-15 09:11:06 UTC
Hi Thorsten,

this BZ looks like a duplicate of BZ 1544470 cn=cacert could show expired certificate (https://bugzilla.redhat.com/show_bug.cgi?id=1544470). Do you agree to close as DUP?

Comment 4 Florence Blanc-Renaud 2019-05-15 11:38:05 UTC

*** This bug has been marked as a duplicate of bug 1544470 ***


Note You need to log in before you can comment on or make changes to this bug.