Bug 1710300 - [OSP15] overcloud deployment with TLS everywhere failed on TASK [install needed packages], "Failed to download packages: Cannot download Packages/openldap-clients-2.4.46-9.el8.x86_64.rpm: All mirrors were tried" [NEEDINFO]
Summary: [OSP15] overcloud deployment with TLS everywhere failed on TASK [install need...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: beta
: 15.0 (Stein)
Assignee: Harry Rybacki
QA Contact: Pavan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-15 09:55 UTC by Artem Hrechanychenko
Modified: 2019-09-26 10:50 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.5.1-0.20190606110437.b9992d9.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:22:03 UTC
Target Upstream Version:
gregraka: needinfo? (hrybacki)
gregraka: needinfo? (hrybacki)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 662276 0 None None None 2019-05-30 18:02:52 UTC
OpenStack gerrit 662291 0 None None None 2019-05-30 18:49:47 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:22:23 UTC

Description Artem Hrechanychenko 2019-05-15 09:55:54 UTC
Description of problem:
https://rhos-qe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/DF%20Current%20release/job/DFG-df-deployment-15-virthost-3cont_3comp_3ceph-yes_UC_SSL-yes_OC_SSL-ceph-ipv4-geneve-TLS_everywhere-RHELOSP-31826/

OSP15 overcloud + TLS everywhere

#!/bin/bash

openstack overcloud deploy \
--timeout 100 \
--templates /usr/share/openstack-tripleo-heat-templates \
--stack overcloud \
--libvirt-type kvm \
--ntp-server clock.redhat.com \
-e /home/stack/virt/internal.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
-e /home/stack/virt/network/network-environment.yaml \
-e /home/stack/virt/network/dvr-override.yaml \
-e /home/stack/virt/enable-tls.yaml \
-e /home/stack/virt/inject-trust-anchor.yaml \
-e /home/stack/virt/public_vip.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/ssl/tls-endpoints-public-ip.yaml \
-e /home/stack/virt/hostnames.yml \
-e /usr/share/openstack-tripleo-heat-templates/environments/ceph-ansible/ceph-ansible.yaml \
-e /home/stack/virt/debug.yaml \
-e /home/stack/virt/nodes_data.yaml \
-e ~/containers-prepare-parameter.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/ssl/tls-everywhere-endpoints-dns.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/services/haproxy-public-tls-certmonger.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/ssl/enable-internal-tls.yaml \
-e /home/stack/virt/cloud-names.yaml \
--log-file overcloud_deployment_91.log

TASK [install needed packages] *************************************************
Tuesday 14 May 2019  12:18:35 +0000 (0:00:00.825)       0:03:29.266 *********** 
skipping: [ceph-0] => (item=ipa-client)  => {"ansible_loop_var": "item", "changed": false, "item": "ipa-client", "skip_reason": "Conditional result was False"}
skipping: [ceph-0] => (item=ipa-admintools)  => {"ansible_loop_var": "item", "changed": false, "item": "ipa-admintools", "skip_reason": "Conditional result was False"}
skipping: [ceph-0] => (item=openldap-clients)  => {"ansible_loop_var": "item", "changed": false, "item": "openldap-clients", "skip_reason": "Conditional result was False"}
skipping: [ceph-0] => (item=hostname)  => {"ansible_loop_var": "item", "changed": false, "item": "hostname", "skip_reason": "Conditional result was False"}
skipping: [ceph-1] => (item=ipa-client)  => {"ansible_loop_var": "item", "changed": false, "item": "ipa-client", "skip_reason": "Conditional result was False"}
skipping: [ceph-1] => (item=ipa-admintools)  => {"ansible_loop_var": "item", "changed": false, "item": "ipa-admintools", "skip_reason": "Conditional result was False"}
skipping: [ceph-1] => (item=openldap-clients)  => {"ansible_loop_var": "item", "changed": false, "item": "openldap-clients", "skip_reason": "Conditional result was False"}
skipping: [ceph-1] => (item=hostname)  => {"ansible_loop_var": "item", "changed": false, "item": "hostname", "skip_reason": "Conditional result was False"}
skipping: [ceph-2] => (item=ipa-client)  => {"ansible_loop_var": "item", "changed": false, "item": "ipa-client", "skip_reason": "Conditional result was False"}
skipping: [ceph-2] => (item=ipa-admintools)  => {"ansible_loop_var": "item", "changed": false, "item": "ipa-admintools", "skip_reason": "Conditional result was False"}
skipping: [ceph-2] => (item=openldap-clients)  => {"ansible_loop_var": "item", "changed": false, "item": "openldap-clients", "skip_reason": "Conditional result was False"}
skipping: [ceph-2] => (item=hostname)  => {"ansible_loop_var": "item", "changed": false, "item": "hostname", "skip_reason": "Conditional result was False"}
skipping: [compute-0] => (item=ipa-client)  => {"ansible_loop_var": "item", "changed": false, "item": "ipa-client", "skip_reason": "Conditional result was False"}
skipping: [compute-0] => (item=ipa-admintools)  => {"ansible_loop_var": "item", "changed": false, "item": "ipa-admintools", "skip_reason": "Conditional result was False"}
skipping: [compute-0] => (item=openldap-clients)  => {"ansible_loop_var": "item", "changed": false, "item": "openldap-clients", "skip_reason": "Conditional result was False"}
skipping: [compute-0] => (item=hostname)  => {"ansible_loop_var": "item", "changed": false, "item": "hostname", "skip_reason": "Conditional result was False"}
skipping: [compute-1] => (item=ipa-client)  => {"ansible_loop_var": "item", "changed": false, "item": "ipa-client", "skip_reason": "Conditional result was False"}
skipping: [compute-1] => (item=ipa-admintools)  => {"ansible_loop_var": "item", "changed": false, "item": "ipa-admintools", "skip_reason": "Conditional result was False"}
skipping: [compute-1] => (item=openldap-clients)  => {"ansible_loop_var": "item", "changed": false, "item": "openldap-clients", "skip_reason": "Conditional result was False"}
skipping: [compute-1] => (item=hostname)  => {"ansible_loop_var": "item", "changed": false, "item": "hostname", "skip_reason": "Conditional result was False"}
skipping: [compute-2] => (item=ipa-client)  => {"ansible_loop_var": "item", "changed": false, "item": "ipa-client", "skip_reason": "Conditional result was False"}
skipping: [compute-2] => (item=ipa-admintools)  => {"ansible_loop_var": "item", "changed": false, "item": "ipa-admintools", "skip_reason": "Conditional result was False"}
skipping: [compute-2] => (item=openldap-clients)  => {"ansible_loop_var": "item", "changed": false, "item": "openldap-clients", "skip_reason": "Conditional result was False"}
skipping: [compute-2] => (item=hostname)  => {"ansible_loop_var": "item", "changed": false, "item": "hostname", "skip_reason": "Conditional result was False"}
ok: [controller-0] => (item=ipa-client) => {"ansible_loop_var": "item", "changed": false, "item": "ipa-client", "msg": "Nothing to do", "rc": 0, "results": ["Installed: ipa-client"]}
ok: [controller-1] => (item=ipa-client) => {"ansible_loop_var": "item", "changed": false, "item": "ipa-client", "msg": "Nothing to do", "rc": 0, "results": ["Installed: ipa-client"]}
ok: [controller-2] => (item=ipa-client) => {"ansible_loop_var": "item", "changed": false, "item": "ipa-client", "msg": "Nothing to do", "rc": 0, "results": ["Installed: ipa-client"]}
ok: [controller-0] => (item=ipa-admintools) => {"ansible_loop_var": "item", "changed": false, "item": "ipa-admintools", "msg": "Nothing to do", "rc": 0, "results": ["Installed: ipa-admintools"]}
ok: [controller-1] => (item=ipa-admintools) => {"ansible_loop_var": "item", "changed": false, "item": "ipa-admintools", "msg": "Nothing to do", "rc": 0, "results": ["Installed: ipa-admintools"]}
ok: [controller-2] => (item=ipa-admintools) => {"ansible_loop_var": "item", "changed": false, "item": "ipa-admintools", "msg": "Nothing to do", "rc": 0, "results": ["Installed: ipa-admintools"]}
failed: [controller-1] (item=openldap-clients) => {"ansible_loop_var": "item", "changed": false, "item": "openldap-clients", "msg": "Failed to download packages: Cannot download Packages/openldap-clients-2.4.46-9.el8.x86_64.rpm: All mirrors were tried", "results": []}
failed: [controller-0] (item=openldap-clients) => {"ansible_loop_var": "item", "changed": false, "item": "openldap-clients", "msg": "Failed to download packages: Cannot download Packages/openldap-clients-2.4.46-9.el8.x86_64.rpm: All mirrors were tried", "results": []}
failed: [controller-2] (item=openldap-clients) => {"ansible_loop_var": "item", "changed": false, "item": "openldap-clients", "msg": "Failed to download packages: Cannot download Packages/openldap-clients-2.4.46-9.el8.x86_64.rpm: All mirrors were tried", "results": []}
ok: [controller-2] => (item=hostname) => {"ansible_loop_var": "item", "changed": false, "item": "hostname", "msg": "Nothing to do", "rc": 0, "results": ["Installed: hostname"]}
ok: [controller-0] => (item=hostname) => {"ansible_loop_var": "item", "changed": false, "item": "hostname", "msg": "Nothing to do", "rc": 0, "results": ["Installed: hostname"]}
ok: [controller-1] => (item=hostname) => {"ansible_loop_var": "item", "changed": false, "item": "hostname", "msg": "Nothing to do", "rc": 0, "results": ["Installed: hostname"]}
Overcloud configuration failed.


NO MORE HOSTS LEFT *************************************************************

PLAY RECAP *********************************************************************
ceph-0                     : ok=70   changed=23   unreachable=0    failed=0    skipped=171  rescued=0    ignored=0   
ceph-1                     : ok=70   changed=23   unreachable=0    failed=0    skipped=171  rescued=0    ignored=0   
ceph-2                     : ok=70   changed=23   unreachable=0    failed=0    skipped=171  rescued=0    ignored=0   
compute-0                  : ok=70   changed=23   unreachable=0    failed=0    skipped=171  rescued=0    ignored=0   
compute-1                  : ok=70   changed=23   unreachable=0    failed=0    skipped=171  rescued=0    ignored=0   
compute-2                  : ok=70   changed=23   unreachable=0    failed=0    skipped=171  rescued=0    ignored=0   
controller-0               : ok=102  changed=53   unreachable=0    failed=1    skipped=138  rescued=0    ignored=0   
controller-1               : ok=102  changed=53   unreachable=0    failed=1    skipped=138  rescued=0    ignored=0   
controller-2               : ok=102  changed=53   unreachable=0    failed=1    skipped=138  rescued=0    ignored=0   
undercloud                 : ok=3    changed=1    unreachable=0    failed=0    skipped=0    rescued=0    ignored=0   

Tuesday 14 May 2019  12:19:24 +0000 (0:00:49.644)       0:04:18.911 *********** 
=============================================================================== 

Ansible failed, check log at /var/lib/mistral/overcloud/ansible.log.



Version-Release number of selected component (if applicable):
core_puddle: RHOS_TRUNK-15.0-RHEL-8-20190509.n.1

How reproducible:
try to install OSP15 with tls everywhere

Steps to Reproduce:
1.Deploy OSP15 with TLS everywhere


Actual results:
Cannot download Packages/openldap-clients-2.4.46-9.el8.x86_64.rpm

Expected results:
installation passed

Additional info:

Blocker because test part of regression

Comment 2 Artem Hrechanychenko 2019-05-22 13:53:36 UTC
hi folks,
any update on this bz?

Comment 17 Artem Hrechanychenko 2019-06-12 14:11:16 UTC
VERIFIED:
openstack-tripleo-heat-templates-10.5.1-0.20190606110437.b9992d9.el8ost.noarch

Comment 21 errata-xmlrpc 2019-09-21 11:22:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.