Bug 171044 - (MPIOU3Proposed) Bugs and features for U3 device-mapper-multipath
Bugs and features for U3 device-mapper-multipath
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Marzinski
: FutureFeature
Depends On: 155428 155738 164197 166284 168538 169074 169089 174084
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-17 13:28 EDT by Ben Marzinski
Modified: 2010-01-11 21:21 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-20 13:26:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Marzinski 2005-10-17 13:28:22 EDT
This is to track which bugs and features are getting done for U3 multipath.
Comment 1 Ben Marzinski 2005-10-17 13:42:34 EDT
This first list of bugs is simply the ones that only effect the user tools and
multipath kernel module or already have upstream fixes. I didn't include the
(168483) I/O Stats and (170552) Load Balancing because it sounds like there are
efforts on these fronts outside of Redhat.  I feel fairly certain that the bugs
listed here will be in U3. I'm pretty certain that we can also include some of
the bugs that require minor device-mapper or SCSI layer changes like 156378,
156385, 156577, and 168801. If people have feelings on the relative priority of
these,
I'd like to know.
Comment 5 Ben Marzinski 2005-10-24 16:46:54 EDT
Oops. I accidentally put 156609 on the depend list, instead of 168538.  156609 is
basically 169538 (when you create a multipath device, you should also create
devices for the partitions on the underlying devices) plus having those partitions
automagically updated when you repartition. For U3, you will have to reload the
device or manually run kpartx after you change the partitions for the change to
be reflected in the multipathed device.
Comment 6 Ben Marzinski 2005-10-26 18:37:52 EDT
Switched 156691 for 169074.  They are the same bug, but 156691 is public facing
and has no ACKs, while 169074 is private and is on the CANFIX list.
Comment 7 Ben Marzinski 2005-12-20 13:26:46 EST
Closing this out, since it's done its job.

Note You need to log in before you can comment on or make changes to this bug.