Bug 171085 - Update to mailman 2.1.6
Update to mailman 2.1.6
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mailman (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-17 19:45 EDT by Reuben Farrelly
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-10 06:00:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2005-10-17 19:45:55 EDT
Mailman 2.1.6 was released in June, but we still have mailman
2.1.5+securitypatch in rawhide.

This is a significant release, which includes three important security patches,
updated Chinese (zh_TW and zh_CN) support, better compatibility with Python 2.4,
a few new features, and many bug fixes.

Can the RPM please be updated to this newer release?
Comment 1 John Dennis 2005-10-18 09:23:33 EDT
It's already done, just not pushed publically, it was waiting for testing.
Perhaps you would like to do that and report back. Here is a link the unofficial
rpm.

ftp://people.redhat.com/jdennis/mailman-2.1.6-1.fc4.i386.rpm
Comment 2 Reuben Farrelly 2005-10-18 22:33:29 EDT
The RPM info (rpm -qi mailman) needs fixing up a bit, the paths are all wrong
and the info is a bit out of date:

* Run /var/mailman/bin/mmsitepass
to set the mailman administrator password.
* Edit /var/mailman/Mailman/mm_cfg.py

etc

Also, there is some duplication of the files such as PythonPowered.png in
/usr/lib/mailman/icons/ and /var/www/icons/  I haven't looked any further to see
if there are other duplications (yet).

Can you also please post the SRPM and I'll have a poke through that also and see
what I can find :)
Comment 3 John Dennis 2005-10-19 08:30:00 EDT
rpm -qi mailman will not produce the output which is currently in the spec file
because it is picking up ancient text from specspo. This is a well known
problem, until specspo gets fixed many packages will produce the wrong info
unless you remove the specspo package from your system. Correct documentation
will be found in /usr/share/doc/mailman-*/INSTALL.REDHAT

I posted the src rpm to the same location.

Thank you for your review.

Note You need to log in before you can comment on or make changes to this bug.