Bug 1711230 - Verification of sysctll is broken for tabs
Summary: Verification of sysctll is broken for tabs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.7
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Robin Hack
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-17 09:47 UTC by Jaroslav Škarvada
Modified: 2019-08-06 13:05 UTC (History)
4 users (show)

Fixed In Version: tuned-2.11.0-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 13:04:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2201 None None None 2019-08-06 13:05:18 UTC

Description Jaroslav Škarvada 2019-05-17 09:47:53 UTC
Description of problem:
The sysctl options such as net.ipv4.tcp_wmem and net.ipv4.tcp_rmem can contain tabs, Tuned doesn't cope with it.

Version-Release number of selected component (if applicable):
tuned-2.11.0-3.el7

How reproducible:
Always

Steps to Reproduce:
1. e.g. set:
[sysctl]
kernel.sem = 1250 256000 100 8192
2. activate the profile
3. tuned-adm verify

Actual results:
Verification fails:
ERROR    tuned.plugins.base: verify: failed: 'kernel.sem' = '1250	256000	100	8192', expected '1250 256000 100 8192'

Expected results:
Verification pass

Additional info:

Comment 2 Jaroslav Škarvada 2019-05-17 09:49:07 UTC
Upstream PR fixing this problem:
https://github.com/redhat-performance/tuned/pull/184

Comment 8 errata-xmlrpc 2019-08-06 13:04:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2201


Note You need to log in before you can comment on or make changes to this bug.