Bug 171157 - CRM# 688270: clvmd unable to handle changes to underlying devices without a restart
Summary: CRM# 688270: clvmd unable to handle changes to underlying devices without a r...
Status: CLOSED DUPLICATE of bug 138396
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: lvm2-cluster   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Alasdair Kergon
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-18 19:53 UTC by Issue Tracker
Modified: 2010-01-12 04:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-01 15:06:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Comment 2 Alasdair Kergon 2006-02-01 14:18:07 UTC
So what's happening here is that devices are appearing/disappearing/changing
underneath the daemon and it's incapable of detecting and responding to this.

Comment 3 Alasdair Kergon 2006-02-01 14:40:23 UTC
I configured a pair of disks, /dev/sdc and /dev/sdd, 1 from each SAN cabinet
into an MD mirror set
and presented that to CLVM2 as pv /dev/md7, created vg wav1_vg and created lv
wav1_v. I then caught
up with the fact that md devices aren/'t supported for GFS so I stripped it back
down and just
put /dev/sdc into the CLVM2 vg. That worked ok. I then went to the SAN and
expanded the size of
/dev/sdc from 1GB to 20GB. I found I had to remove it from CLVM2 again in order
to get the PV extents to
change. After fiddling with fdisk, partprobe, etc I finally got CLVM2 to
recognize the changed size and
re-created the lv. When CLVM2 tried to active it I got the internal error and
this was put in the
/var/log/messages file : 
 
Sep 23 14:55:27 blue-1 lvm[2788]: Volume group for uuid not found:
QJpYmayZB3IyOPzAu6PvQBRJq5o4sRN 
y3ZSAL8nBfOTm15j253LrslM6QxQs0RCq 
Sep 23 14:55:27 blue-1 lvm[2788]: /dev/sdc1: stat failed: No such file or directory 
Sep 23 14:55:27 blue-1 lvm[2788]: Path /dev/sdc1 no longer valid for device(8,33) 
Sep 23 14:55:27 blue-1 lvm[2788]: Aborting - please provide new pathname for
what used to be /dev/ 
sdc1 
Sep 23 14:55:27 blue-1 lvm[2788]: /dev/sdd1: stat failed: No such file or directory 
Sep 23 14:55:27 blue-1 lvm[2788]: Path /dev/sdd1 no longer valid for device(8,49) 
Sep 23 14:55:27 blue-1 lvm[2788]: Aborting - please provide new pathname for
what used to be /dev/ 
sdd1 

Comment 5 Alasdair Kergon 2006-02-01 15:06:29 UTC

*** This bug has been marked as a duplicate of 138396 ***


Note You need to log in before you can comment on or make changes to this bug.