Bug 171165 - openldap should give useful error messages on permissions problems
openldap should give useful error messages on permissions problems
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openldap (Show other bugs)
4.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jan Safranek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-18 17:43 EDT by Josh Kelley
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2007-0739
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:03:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Kelley 2005-10-18 17:43:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
If slapd is configured to use a certificate file or certificate key file that isn't readable by the LDAP user, it fails to start without displaying any useful error message.  Since most services access their certificate keys as root before dropping permissions, checking that the cert keys are readable by the ldap user is not intuitive.

Version-Release number of selected component (if applicable):
openldap-2.2.13-4

How reproducible:
Always

Steps to Reproduce:
1. Edit /etc/openldap/slapd.conf and configure a TLSCertificateFile and TLSCertificateKeyFile.
2. Make one or both files not readable by the ldap user.
3. Start LDAP ("service slapd start").


Actual Results:  "[FAILED]"

Expected Results:  Error message explaining why it failed.

Additional info:
Comment 1 Jan Safranek 2007-06-21 10:25:09 EDT
init script will now display [WARNINIG] which will describe permission problem
(as in RHEL 5 and Fedora)
Comment 2 RHEL Product and Program Management 2007-06-21 10:34:10 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 errata-xmlrpc 2007-11-15 11:03:52 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0739.html

Note You need to log in before you can comment on or make changes to this bug.