Bug 1711654 - After upgrade to Fedora 30, bluetooth audio stopped working [NEEDINFO]
Summary: After upgrade to Fedora 30, bluetooth audio stopped working
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: bluez
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Don Zickus
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-19 10:33 UTC by Nadav Har'El
Modified: 2019-06-07 08:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
bnocera: needinfo? (nyh)


Attachments (Terms of Use)

Description Nadav Har'El 2019-05-19 10:33:52 UTC
In Fedora 29, I used my bluetooth USB dongle to play music on an external Bluetooth speaker. The dongle is:

$ lsusb
Bus 003 Device 004: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

to use it I did:
$ bluetoothctl
connect 70:99:1C:19:A1:6D

And everything worked well.
In fedora 30, this stopped working:

# bluetoothctl
Agent registered
[bluetooth]# connect 70:99:1C:19:A1:6D
Attempting to connect to 70:99:1C:19:A1:6D
Failed to connect: org.bluez.Error.Failed
[bluetooth]# 

journalctl shows:
May 19 13:30:23 pooh bluetoothd[887]: a2dp-sink profile connect failed for 70:99:1C:19:A1:6D: Protocol not available


I don't know what I might be missing. As I said, prior to the upgrade this worked well, so apparently I had all the necessary packages installed. Also I see

$ pactl list short modules| grep blue
8       module-bluetooth-policy
9       module-bluetooth-discover
10      module-bluez5-discover

Comment 1 Didier G 2019-05-19 14:20:03 UTC
Which kernel do you use ?

See: https://bugzilla.redhat.com/show_bug.cgi?id=1711468

Comment 2 Nadav Har'El 2019-05-19 14:58:19 UTC
$ uname -a
Linux pooh 5.0.16-300.fc30.x86_64 #1 SMP Tue May 14 19:33:09 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Comment 3 Nadav Har'El 2019-05-25 20:01:14 UTC
I just upgrade my kernel to

$ uname -a
Linux pooh 5.0.17-300.fc30.x86_64 #1 SMP Mon May 20 15:36:26 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

And am still facing the same problem.

Comment 4 Bastien Nocera 2019-06-05 10:47:43 UTC
Could you please test with kernel 5.1.5 (or newer)?

Comment 5 Nadav Har'El 2019-06-06 14:47:58 UTC
Unfortunately, I don't see any improvement or change on

$ uname -a
Linux pooh 5.1.5-300.fc30.x86_64 #1 SMP Sat May 25 18:00:11 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

As before, bluetoothctl's connect fails, and I get this in the log:
dp-sink profile connect failed for 70:99:1C:19:A1:6D: Protocol not available

Comment 6 Bastien Nocera 2019-06-07 08:10:56 UTC
Please test with the bluez-5.50-8 bluez update at:
https://bodhi.fedoraproject.org/updates/FEDORA-2019-5101717387

There are a number of fixes that should help.


Note You need to log in before you can comment on or make changes to this bug.