Bug 1711743 - [NetKVM] around 20% Rx performance regression on Win 10 with virtio-win-prewhql-0.1-162
Summary: [NetKVM] around 20% Rx performance regression on Win 10 with virtio-win-prewh...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: virtio-win
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.2
Assignee: ybendito
QA Contact: Quan Wenli
URL:
Whiteboard:
Depends On:
Blocks: 1746622 1771318
TreeView+ depends on / blocked
 
Reported: 2019-05-20 03:26 UTC by Quan Wenli
Modified: 2020-08-10 13:48 UTC (History)
9 users (show)

Fixed In Version: virtio-win-prewhql-0.1-174
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:05:15 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:1757 None None None 2020-04-28 16:06:07 UTC

Comment 15 ybendito 2019-07-23 09:39:18 UTC
Do you have a technical ability to test performance on external link > 10 Gbps?
If yes, do you have a test results on such setup?

Comment 16 Quan Wenli 2019-07-24 03:28:39 UTC
(In reply to ybendito from comment #15)
> Do you have a technical ability to test performance on external link > 10
> Gbps?
> If yes, do you have a test results on such setup?


we have two 40Gb cards but no results, what's speed result do you need with 160 and 162.

Comment 17 ybendito 2019-07-24 07:21:17 UTC
We'd like to have 3 tests on 40 Gbps link:
1) 160 as is,
2) 160 with speed=40000 (40,000 )
3) 160 with speed=100000 (100,000)
Is it possible?

Comment 18 Quan Wenli 2019-07-24 08:06:08 UTC
(In reply to ybendito from comment #17)
> We'd like to have 3 tests on 40 Gbps link:
> 1) 160 as is,
> 2) 160 with speed=40000 (40,000 )
> 3) 160 with speed=100000 (100,000)
> Is it possible?

yes, it's possible, what's comparison do you want, 1 vs 2 and 1 vs 3 ?

Comment 19 ybendito 2019-07-24 08:10:06 UTC
(In reply to Quan Wenli from comment #18)
> (In reply to ybendito from comment #17)
> > We'd like to have 3 tests on 40 Gbps link:
> > 1) 160 as is,
> > 2) 160 with speed=40000 (40,000 )
> > 3) 160 with speed=100000 (100,000)
> > Is it possible?
> 
> yes, it's possible, what's comparison do you want, 1 vs 2 and 1 vs 3 ?

Yes, for example

Comment 20 Quan Wenli 2019-07-26 05:48:54 UTC
(In reply to ybendito from comment #19)
> (In reply to Quan Wenli from comment #18)
> > (In reply to ybendito from comment #17)
> > > We'd like to have 3 tests on 40 Gbps link:
> > > 1) 160 as is,
> > > 2) 160 with speed=40000 (40,000 )
> > > 3) 160 with speed=100000 (100,000)
> > > Is it possible?
> > 
> > yes, it's possible, what's comparison do you want, 1 vs 2 and 1 vs 3 ?
> 
> Yes, for example

In 40Gb network, we still could see the degradation with speed=40000 and speed=100000([1][2]) compared with default setting and performance with speed=40000 is better than speed=10000([3]). 

1. 160 vs 160 with speed=40000 (40,000)

http://kvm-perf.englab.nay.redhat.com/results/regression/2019-05-13-network-8.0.1-virtio-win-prewhql171/bug/speed10000/xl710_160_speed40000/Win10.i386.*.netperf.with_jumbo.host_guest.html

http://kvm-perf.englab.nay.redhat.com/results/regression/2019-05-13-network-8.0.1-virtio-win-prewhql171/bug/speed10000/xl710_160_speed40000/Win10.x86_64.*.netperf.with_jumbo.host_guest.html


2. 160 vs 160 with speed=100000 (100,000)

http://kvm-perf.englab.nay.redhat.com/results/regression/2019-05-13-network-8.0.1-virtio-win-prewhql171/bug/speed10000/xl710_160_speed100000/Win10.i386.*.netperf.with_jumbo.host_guest.html

http://kvm-perf.englab.nay.redhat.com/results/regression/2019-05-13-network-8.0.1-virtio-win-prewhql171/bug/speed10000/xl710_160_speed100000/Win10.x86_64.*.netperf.with_jumbo.host_guest.html

3. 160 with speed=40000 vs 160 with speed=100000

http://kvm-perf.englab.nay.redhat.com/results/regression/2019-05-13-network-8.0.1-virtio-win-prewhql171/bug/speed10000/xl710_40000vs100000/Win10.i386.*.netperf.with_jumbo.host_guest.html

http://kvm-perf.englab.nay.redhat.com/results/regression/2019-05-13-network-8.0.1-virtio-win-prewhql171/bug/speed10000/xl710_40000vs100000/Win10.x86_64.*.netperf.with_jumbo.host_guest.html

Comment 24 lijin 2019-12-13 05:57:29 UTC
prewhql-174 fix it.

wenli,

Could you help to verify this bug with 174 version?

Thanks.

Comment 32 errata-xmlrpc 2020-04-28 16:05:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:1757


Note You need to log in before you can comment on or make changes to this bug.