This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 171178 - bind-utils should Require: bind-libs
bind-utils should Require: bind-libs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: bind (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Ben Levenson
: FutureFeature
Depends On:
Blocks: 176344
  Show dependency treegraph
 
Reported: 2005-10-18 23:34 EDT by Gordon Rowell
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2006-0711
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-03 11:15:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Rowell 2005-10-18 23:34:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
Note: This is a "custom" ISO issue, and so low priority. Raised here for your consideration.

It is possible to install bind-utils without bind-libs, and dig fails:

  dig: error while loading shared libraries: libdns.so.16:
  cannot open shared object file: No such file or directory

There are library dependencies between the two packages, but "yum" doesn't feel this is sufficient to pull in the bind-utils package.

There should probably be the following in the SPEC file:

%package utils
Summary: Utilities for querying DNS name servers.
Group: Applications/System
+Requires: bind-libs


Version-Release number of selected component (if applicable):
bind-9.3.1-4

How reproducible:
Always

Steps to Reproduce:
Create a custom ISO containing bind-utils, but not bind-libs.

(Yes, I know, don't do that...)
  

Actual Results:  dig: error while loading shared libraries: libdns.so.16:
cannot open shared object file: No such file or directory


Expected Results:  dig should work, which it does with a standard install.

Additional info:

Noticed which building SME Server Release 7 ISO:

https://sourceforge.net/tracker/index.php?func=detail&aid=1264555&group_id=96750&atid=615772
Comment 1 Jason Vas Dias 2005-10-19 11:43:06 EDT
Yes, you're quite right - bind-utils should 'Require: bind-libs' - it is 
amazing this was overlooked until now.
RPM should not have installed bind-utils without bind-libs being installed
because of the missing dependencies. 
You're using the bind-9.3.1-4 RPMs from :
    http://people.redhat.com/~jvdias/bind/RHEL-4/ ?
I'll update these to include the missing Requires: and append to this bug when
done.
Comment 2 Gordon Rowell 2005-10-19 18:26:30 EDT
FTR - The bind-9.3.1-4 SRPM I checked was from the FC4 tree. We're using the one
from RHEL 4.1/CentOS 4.1, but the issue exists in latest, as you have found.
Comment 3 J. Nick Koston 2006-07-23 15:17:31 EDT
This is a pretty sticky issue since updating bind without explicitly specifying
bind-libs currently breaks a working bind install.  
Comment 4 Marcelo Giles 2006-08-16 18:35:18 EDT
I've come across this dependency problem when I updated bind-9.2.4-2 to
bind-9.2.4-16 via up2date. 

This version of bind was updated in RHEL4 U4.

up2date bind

# service named start
Starting named: /usr/sbin/named: symbol lookup error: /usr/sbin/named: undefined
symbol: dns_resolver_setudpsize
                                                           [FAILED] 

So I had to manually update bind-libs. After that, named started ok.

up2date bind-libs

# service named start
Starting named:                                            [  OK  ]
Comment 10 Red Hat Bugzilla 2006-11-03 11:15:03 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0711.html

Note You need to log in before you can comment on or make changes to this bug.