Bug 171182 - CJK and Indic layout issue when printing from evolution cal
CJK and Indic layout issue when printing from evolution cal
Status: CLOSED DUPLICATE of bug 157393
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
: i18n
Depends On: 140309
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-19 01:23 EDT by Lawrence Lim
Modified: 2014-03-25 20:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-11 03:52:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2005-10-19 01:23:45 EDT
+++ This bug was initially created as a clone of Bug #140309 +++

Description of problem:
Printing the entries from the Evolution Calendars for CJK languages
has a common behaviour.

For zh_TW, ja_JP and ko_KO,
The numeric hours and the native characters which define the AM/PM are
overlapping.

Version-Release number of selected component (if applicable):
evolution-data-server-1.4.0-2
evolution-webcal-2.4.0.1-2
evolution-2.4.0-2


How reproducible:
Always

Steps to Reproduce:
1.start evolution in any of the CJK locale, eg, LANG=zh_TW.UTF-8 evolution
2.click on the Calendar
3.print the Calendar

Actual results:
Please see the attached .ps file for each locale

Expected results:
Consistent with what is displayed on the screen

Additional info:
-- Additional comment from llim@redhat.com on 2005-03-31 00:12 EST --
Created an attachment (id=112502)
ps file for hi_IN locale


-- Additional comment from llim@redhat.com on 2005-03-31 00:13 EST --
Created an attachment (id=112503)
ps file for the ko_KR locale


-- Additional comment from dmalcolm@redhat.com on 2005-03-31 11:49 EST --
Am in right in thinking that in attachment 112502 [details] and attachment 112503 [details], the
string description following the numeric part of the time is getting clipped on
its right hand side?

Looks like we need to position the X-coordinate about which the times are
rendered so that there's enough room (see description in column #9).   This will
need to work for every locale, so I'm thinking of determining this algorithmically.

-- Additional comment from tagoh@redhat.com on 2005-06-20 03:10 EST --
Yes, apparently it's getting clipped on the right hand side and the column for
the time has to be growed. your solution will fixes this I believe.
Comment 1 Leon Ho 2006-07-11 03:52:19 EDT

*** This bug has been marked as a duplicate of 157393 ***

Note You need to log in before you can comment on or make changes to this bug.