Bug 1711879 - [DR]Run: /usr/local/bin/etcd-snapshot-restore.sh failed with err:failed resolving host :2380 (lookup : no such host)
Summary: [DR]Run: /usr/local/bin/etcd-snapshot-restore.sh failed with err:failed resol...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.1.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 4.1.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-20 09:52 UTC by ge liu
Modified: 2019-06-04 10:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:48:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:49:44 UTC

Description ge liu 2019-05-20 09:52:27 UTC
Description of problem:

As title,

got err:

2019-05-20 09:16:17.341538 W | pkg/netutil: failed resolving host :2380 (lookup : no such host); retrying in 1s
2019-05-20 09:16:18.334707 E | pkg/netutil: could not resolve host :2380
Error: --initial-cluster has etcd-member-ip-10-0-135-211.eu-central-1.compute.internal=https://:2380 but missing from --initial-advertise-peer-urls=https://10.0.135.211:2380 (failed to resolve "https://:2380" (lookup : no such host))

4.1.0-0.nightly-2019-05-18-050636


How reproducible:
Always

Steps to Reproduce:

1. Stop etcd-0(etcd leader), etcd-1(member) node in aws console
2. login etcd-2 with bastion node
3. $  sudo -E /usr/local/bin/etcd-snapshot-restore.sh 

Restoring etcd member etcd-member-ip-10-0-135-211.eu-central-1.compute.internal from snapshot..
2019-05-20 09:15:48.334481 W | pkg/netutil: failed resolving host :2380 (lookup : no such host); retrying in 1s
2019-05-20 09:15:49.334783 W | pkg/netutil: failed resolving host :2380 (lookup : no such host); retrying in 1s
2019-05-20 09:15:50.334991 W | pkg/netutil: failed resolving host :2380 (lookup : no such host); retrying in 1s

tried add or don't add '-E', both got same failure.

Actual results:
As title
Expected results:

Comment 4 Xingxing Xia 2019-05-24 09:06:03 UTC
This is verified in 4.1.0-0.nightly-2019-05-24-040103 during verifying https://bugzilla.redhat.com/show_bug.cgi?id=1709802#c15 , no error met.

Comment 6 errata-xmlrpc 2019-06-04 10:48:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.