Bug 171195 - NetworkManager fails to connect claiming /sbin/dhcdbd cannot be found
NetworkManager fails to connect claiming /sbin/dhcdbd cannot be found
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-19 08:02 EDT by Kristian Harms
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-20 16:19:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kristian Harms 2005-10-19 08:02:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; nb-NO; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
For the past month or so, I've been using the NetworkManager the came with FC4 on my pretty standard FC4 installation.  Today, I followed the directions in Aillon's blog for installing NetworkManager 0.5 on Fedora core 4.

After a reboot, I found that NetworkManager hadn't automatically connected.  I clicked on the tray icon, there were no visible wireless networks listed (my own wireless network doesn't broadcast essid and is wep-encrypted.  I chose to connect to a network, typed in my Essid and WEP key.

The tray icon at this point swirled in the familiar fashion, with two small balls inside, indicating it was trying to connect.

However after maybe 30, it stopped and asked me again for the encryption key.  (Yes, I tried the various different encryption types, and I'm sure i gave the correct one.)

I had a look in /var/log/messages, and found some interesting things.  At various places that seem to coincide with me having tried to get NetworkManager to connect, I found this message:

Oct 19 13:19:37 bull NetworkManager: <WARNING>    (): Could not activate the DHCP daemon /sbin/dhcdbd.  error: 'Failed to execute child process "/sbin/dhcdbd" (No such file or directory)'.
Oct 19 13:20:08 bull last message repeated 504 times
Oct 19 13:20:18 bull last message repeated 213 times

(Number of repetions vary from 1 to many hundreds, as you see here.)

Is dhcdbd correct?  The file doesn't exist on my system.  Neither does it exist in any yum repo that I have installed, if "yum provides dhcdbd" is to be believed.

I do however have /sbin/dhclient, which is a daemon for doing DHCP magic I believe.  It also wrote something to the log, as a matter infact.  Here's what it wrote, together with some other messages so that you may see it in the propper context:

Oct 19 13:17:27 bull NetworkManager: <WARNING>    (): Could not activate the DHCP daemon /sbin/dhcdbd.  error: 'Failed to execute child process "/sbin/dhcdbd" (No such file or directory)'.
Oct 19 13:17:29 bull dhclient: Internet Systems Consortium DHCP Client V3.0.2-RedHat
Oct 19 13:17:29 bull dhclient: Copyright 2004 Internet Systems Consortium.
Oct 19 13:17:29 bull dhclient: All rights reserved.
Oct 19 13:17:29 bull dhclient: For info, please visit http://www.isc.org/products/DHCP
Oct 19 13:17:29 bull dhclient:
Oct 19 13:17:29 bull dhclient: Listening on LPF/eth1/00:0d:54:9d:08:b5
Oct 19 13:17:29 bull dhclient: Sending on   LPF/eth1/00:0d:54:9d:08:b5
Oct 19 13:17:29 bull dhclient: Sending on   Socket/fallback
Oct 19 13:17:29 bull dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
Oct 19 13:17:34 bull NetworkManager: <WARNING>    (): Could not activate the DHCP daemon /sbin/dhcdbd.  error: 'Failed to execute child process "/sbin/dhcdbd" (No such file or directory)'.
Oct 19 13:17:36 bull dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 9
Oct 19 13:17:40 bull dhclient: receive_packet failed on eth1: Network is down
Oct 19 13:17:45 bull dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
Oct 19 13:17:45 bull dhclient: DHCPOFFER from 192.168.1.1
Oct 19 13:17:45 bull dhclient: DHCPREQUEST on eth1 to 255.255.255.255 port 67
Oct 19 13:17:45 bull dhclient: DHCPACK from 192.168.1.1
Oct 19 13:17:46 bull dhclient: Internet Systems Consortium DHCP Client V3.0.2-RedHat
Oct 19 13:17:46 bull dhclient: Copyright 2004 Internet Systems Consortium.
Oct 19 13:17:46 bull dhclient: All rights reserved.
Oct 19 13:17:46 bull dhclient: For info, please visit http://www.isc.org/products/DHCP
Oct 19 13:17:46 bull dhclient:
Oct 19 13:17:46 bull dhclient: Listening on LPF/eth1/00:0d:54:9d:08:b5
Oct 19 13:17:46 bull dhclient: Sending on   LPF/eth1/00:0d:54:9d:08:b5
Oct 19 13:17:46 bull dhclient: Sending on   Socket/fallback
Oct 19 13:17:46 bull dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
Oct 19 13:17:47 bull dhclient: DHCPOFFER from 192.168.1.1
Oct 19 13:17:47 bull dhclient: DHCPREQUEST on eth1 to 255.255.255.255 port 67
Oct 19 13:17:47 bull dhclient: DHCPACK from 192.168.1.1
Oct 19 13:17:47 bull NET[2759]: /sbin/dhclient-script : updated /etc/resolv.conf
Oct 19 13:17:47 bull dhclient: bound to 192.168.1.190 -- renewal in 17594 seconds.
Oct 19 13:17:51 bull dhclient: receive_packet failed on eth1: Network is down
Oct 19 13:18:23 bull dhclient: receive_packet failed on eth1: Network is down


Version-Release number of selected component (if applicable):
NetworkManager-0.5.0-1.FC4.1

How reproducible:
Always

Steps to Reproduce:
1. Install NetworkManager 0.5 on FC4
2. Try to connect to a wireless network (with hidden essid and wep-encrypted in my case) in the usual way
3. If necessary, re-enter details of the network if they don't carry over from before the upgrade.
  

Actual Results:  No network, strange messages in /var/log/messages about not finding /sbin/dhcdbd.

Expected Results:  A wireless network connection allowing one to use the web, bugzilla, email, IRC, do yum update and so on :-)

Additional info:

I was in a little bit of doubt in the question of this is an fc4 bug or a devel bug, so feel free so rebrand it as whatever you feel is correct.
Comment 1 Christopher Aillon 2005-10-19 09:56:27 EDT
Run `yum install dhcdbd` -- I will update my blog.  :-)
Comment 2 Christopher Aillon 2005-10-19 10:01:09 EDT
(It's in the updates-testing repo that you got NetworkManager from.)
Comment 3 Christopher Aillon 2005-10-19 10:06:25 EDT
Building a new NetworkManager with Requires: dhcdbd.  It will hit the same repo
later today.
Comment 4 Kristian Harms 2005-10-19 10:53:36 EDT
I've installed dhcdbd from updates-testing now, but it still doesn't work.  I'm
sorry to ruin your day like this :-)

When I now direct NetworkManager to connect to my network, the tray icon starts
swirling with the two little balls inside it, but it just goes on and doesn't
reask about the encryption key.  The only thing showing up in the log is:

Oct 19 16:35:27 bull dhcdbd: Started up.
Oct 19 16:35:28 bull dhcdbd: message_handler: message handler not found under
/com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.reason

Five minutes later when I had plugged in my oldfashioned ethernet cable, I got
some more messages in the log, indicating that dhclient got me an IP from the
DHCP server in the wireless router, and that dhcdbd still didn't work:

Oct 19 16:40:00 bull kernel: eth0: Autonegotiation advertising 0x5e1  partner
0x45e1.
Oct 19 16:40:00 bull kernel: eth0: link up.
Oct 19 16:40:00 bull kernel: eth0: Setting full-duplex based on negotiated link
capability.
Oct 19 16:40:00 bull dhcdbd: message_handler: message handler not found under
/com/redhat/dhcp/eth0 for sub-path eth0.dbus.get.reason
Oct 19 16:40:02 bull dhclient: Internet Systems Consortium DHCP Client V3.0.2-RedHat
Oct 19 16:40:02 bull dhclient: Copyright 2004 Internet Systems Consortium.
Oct 19 16:40:02 bull dhclient: All rights reserved.
Oct 19 16:40:02 bull dhclient: For info, please visit
http://www.isc.org/products/DHCP
Oct 19 16:40:02 bull dhclient:
Oct 19 16:40:02 bull dhclient: Listening on LPF/eth0/00:0b:cd:e8:44:e3
Oct 19 16:40:02 bull dhclient: Sending on   LPF/eth0/00:0b:cd:e8:44:e3
Oct 19 16:40:02 bull dhclient: Sending on   Socket/fallback
Oct 19 16:40:02 bull dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67
interval 3
Oct 19 16:40:02 bull dhclient: DHCPOFFER from 192.168.1.1
Oct 19 16:40:02 bull dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
Oct 19 16:40:02 bull dhclient: DHCPACK from 192.168.1.1
Oct 19 16:40:02 bull dhcdbd: message_handler: message handler not found under
/com/redhat/dhcp/eth0 for sub-path eth0.dbus.get.domain_name
Oct 19 16:40:02 bull NetworkManager: <WARNING>    (): get_ip4_string(): error
calling 'domain_name', DHCP daemon returned error
'org.freedesktop.DBus.Error.UnknownMethod', message 'Method "domain_name" with
signature "" on interface "com.redhat.dhcp.dbus.get" doesn't exist '.
Oct 19 16:40:02 bull dhclient: bound to 192.168.1.236 -- renewal in 21281 seconds.

(I hope it's okay that I put this in the same bug report, since the original
problem was basically solved in no-time.)
Comment 5 Christopher Aillon 2005-10-19 15:09:54 EDT
Did it pull down a new wireless-tools, too?  If so, does a reboot fix it?  If
not, does `yum --enablerepo=updates-testing update wireless-tools` help?
Comment 6 Kristian Harms 2005-10-19 15:33:55 EDT
No, it did not pull down a new wireless-tools, and yes, fetching it did help. 
I'm now submitting this text across my wireless connection.

There are still error messages in the log, and it's still dhclient that does the
DHCP job:

Oct 19 21:31:50 bull dhcdbd: message_handler: message handler not found under
/com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.domain_name
Oct 19 21:31:50 bull NetworkManager: <WARNING>    (): get_ip4_string(): error
calling 'domain_name', DHCP daemon returned error
'org.freedesktop.DBus.Error.UnknownMethod', message 'Method "domain_name" with
signature "" on interface "com.redhat.dhcp.dbus.get" doesn't exist '.
Oct 19 21:31:50 bull dhclient: bound to 192.168.1.190 -- renewal in 18911 seconds.
Comment 7 Christopher Aillon 2005-10-20 16:19:03 EDT
Resolving this as fixed.  The dhcdbd thing is a warning and is apparently
normal, I'm told.

yum --enablerepo=updates-testing update NetworkManager

will pull a new NetworkManager which sucks down dhcdbd and wireless-tools as well.

Note You need to log in before you can comment on or make changes to this bug.