Bug 171210 - tar crashes with glibc error
tar crashes with glibc error
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tar (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Brich
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-19 10:34 EDT by Per Steinar Iversen
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 05:48:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Per Steinar Iversen 2005-10-19 10:34:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Amanda uses tar to get an estimate of the job to be done, according to the amanda logs the command is like this:

/bin/tar --create --file /dev/null --directory /home --one-file-system --listed-incremental /tmp/hm.txt --sparse
--ignore-failed-read --totals .

Recently, after AS4 U2, amanda started to die in this step for one partition on one machine. When the command is run under gdb we get this:

(gdb) run --create --file /dev/null --directory /home --one-file-system--listed-incremental /tmp/hm.txt --sparse --ignore-failed-read --totals .
(no debugging symbols found)
(no debugging symbols found)
*** glibc detected *** free(): invalid pointer: 0x0049309c ***

Program received signal SIGABRT, Aborted.
0x003527a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2

(gdb) bt
#0  0x003527a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x003927d5 in raise () from /lib/tls/libc.so.6
#2  0x00394149 in abort () from /lib/tls/libc.so.6
#3  0x003c640a in __libc_message () from /lib/tls/libc.so.6
#4  0x003ccb3f in _int_free () from /lib/tls/libc.so.6
#5  0x003cceba in free () from /lib/tls/libc.so.6
#6  0x00461aee in nscd_getpw_r () from /lib/tls/libc.so.6
#7  0x00461ba7 in __nscd_getpwuid_r () from /lib/tls/libc.so.6
#8  0x003f467a in getpwuid_r@@GLIBC_2.1.2 () from /lib/tls/libc.so.6
#9  0x003f4121 in getpwuid () from /lib/tls/libc.so.6
#10 0x08059303 in ?? ()
#11 0x0000b337 in ?? ()
#12 0x0000000c in ?? ()
#13 0x08066881 in _IO_stdin_used ()
#14 0xbfff72f4 in ?? ()
#15 0x00000000 in ?? ()


Version-Release number of selected component (if applicable):
tar-1.14-8.RHEL4

How reproducible:
Always

Steps to Reproduce:
1. Make backup with amanda
2. /bin/tar dies
3.
  

Actual Results:  /bin/tar dies with glibc error message.

Expected Results:  The backup job should archive our files.

Additional info:
Comment 1 Per Steinar Iversen 2005-10-19 12:26:55 EDT
Turned off nscd and suddenly tar worked fine, so this is probably a bug in nscd,
not tar.
Comment 2 Peter Vrabec 2005-10-20 12:09:16 EDT
I can't reproduce it. It doesn't matter if nscd is turned on or off.
Comment 3 Per Steinar Iversen 2005-10-21 04:37:50 EDT
This only happen on one of several servers we run  with AS4 U2 on. There is
nothing really special about the machine and it is very stable, no hardware
problems for example. The filesystem that causes the problem has files for many
different users, about 17k - perhaps this causes the nscd problem.
Comment 4 Lukas Vrabel 2007-03-30 08:27:04 EDT
Hi, is the problem still actual or has it been already fixed?
Comment 5 Per Steinar Iversen 2007-03-30 08:39:46 EDT
It seems to happen still but very rarely now, once this year I believe.
Comment 6 Lukas Vrabel 2007-04-03 08:27:58 EDT
Can you post steps (or config) that 100% reproduce the bug please?
Comment 7 RHEL Product and Program Management 2007-05-24 06:06:07 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 8 Radek Brich 2007-10-02 05:48:16 EDT
I cannot reproduce this bug, closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.