Bug 1712189 - NextCloud on F30 not usable
Summary: NextCloud on F30 not usable
Keywords:
Status: CLOSED DUPLICATE of bug 1710115
Alias: None
Product: Fedora
Classification: Fedora
Component: nextcloud
Version: 30
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Ivan Chavero
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1710115
TreeView+ depends on / blocked
 
Reported: 2019-05-21 01:06 UTC by Avi Alkalay
Modified: 2020-02-08 20:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-08 20:29:31 UTC
Type: Bug


Attachments (Terms of Use)

Description Avi Alkalay 2019-05-21 01:06:24 UTC
Description of problem:
Can't finish NextCloud installation. Stops with different problems with SQLite and MariaDB.

Version-Release number of selected component (if applicable):
# rpm -qa | grep nextcloud | sort
nextcloud-10.0.4-7.fc30.noarch
nextcloud-httpd-10.0.4-7.fc30.noarch
nextcloud-mysql-10.0.4-7.fc30.noarch
nextcloud-sqlite-10.0.4-7.fc30.noarch

How reproducible:
Install nextcloud and MariaDB and try to make it work.


Actual results:

This is what happens when I try to initialize nextcloud setting an admin user:

With SQLite it fails in the database creation phase with an error message related to duplicate table primary key.

With a pre-configured MariaDB, I get a white screen of death with no further clues.


Expected results:
This stuff could simply work.

Comment 1 Sam Tygier 2019-10-02 21:52:34 UTC
Dupe of #1710115

Comment 2 Ivan Chavero 2020-02-08 20:29:31 UTC
I took ownership of the nextcloud package, i made a major refactor to the spec file and updated it to the current version (18.0.0).
The package has now been uploaded and built successfully [1].





[1] https://koji.fedoraproject.org/koji/packageinfo?packageID=23789

*** This bug has been marked as a duplicate of bug 1710115 ***


Note You need to log in before you can comment on or make changes to this bug.