Bug 171224 - fontconfig breaks firefox
fontconfig breaks firefox
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-19 12:24 EDT by John Ellson
Modified: 2013-03-05 22:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-20 12:24:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2005-10-19 12:24:54 EDT
Description of problem:
Latest fontconfig breaks firefox.  Firefox quits without error mesage before
opening window.

Version-Release number of selected component (if applicable):
fontconfig-devel-2.3.91.cvs20051017-1
firefox-1.5-0.5.0.beta2

How reproducible:
100%

Steps to Reproduce:
1.firefox --debug
2.
3.
  
Actual results:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 46912501427328 (LWP 28890)]
0x00000037d6518b7e in FcCharSetCopy () from /usr/lib64/libfontconfig.so.1


Expected results:


Additional info:
Problem fixed by reverting to fontconfig-2.3.2-1
Comment 1 Sammy 2005-10-20 12:07:19 EDT
I am running i386 version of  firefox-1.5-0.5.0.beta2 on my X86_64 system and 
it is working fine with the new fontconfig-cvs (I do this so that I can use plugins like 
flash, etc which do not have 86_64 versions). 
 
So, it seems like something may be wrong in the X86_64 version of fontconfig-cvs. 
Comment 2 John Ellson 2005-10-20 12:24:25 EDT
I don't know.  I re-upgraded to fontconfig-2.3.91.cvs20051017-1 today, after
today's other rawhide uprades, and now I can't recreate  the problem.

I tried with my regular .mozilla/firefox/  configuration, and with that moved
aside to get a vanilla configuration.

The other thing I've done since yesterday is to log out and log back in, so
perhaps there was a corrupted font cache thats been cleared now.

Probably we should abandon this report unless I can recreate it.

Changed to:  WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.