Bug 171241 - hide the input method context menu by default
hide the input method context menu by default
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks: Yellowpad
  Show dependency treegraph
 
Reported: 2005-10-19 16:02 EDT by Matthias Clasen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-24 16:26:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gtk patch (10.31 KB, patch)
2005-10-19 16:02 EDT, Matthias Clasen
no flags Details | Diff
control-center patch (775 bytes, patch)
2005-10-19 16:12 EDT, Matthias Clasen
no flags Details | Diff
libgnome patch (1.27 KB, patch)
2005-10-19 16:21 EDT, Matthias Clasen
no flags Details | Diff

  None (edit)
Description Matthias Clasen 2005-10-19 16:02:44 EDT
After discussing scim with Warren, we want the "Input Methods" submenu to be
hidden, since input method switching should be done with the scim notification
area icon. Might be worth hiding the "Control Character" menu at the same time.

I'll attach for gtk which adds to settings for this, and exposes them as
xsettings. Still to do: patch gnome-settings-manager to wire them to gconf keys,
and add the gconf keys to a suitable schema.
Comment 1 Matthias Clasen 2005-10-19 16:02:45 EDT
Created attachment 120170 [details]
gtk patch
Comment 2 Matthias Clasen 2005-10-19 16:12:28 EDT
Created attachment 120171 [details]
control-center patch
Comment 3 Matthias Clasen 2005-10-19 16:21:28 EDT
Created attachment 120172 [details]
libgnome patch
Comment 4 Matthias Clasen 2005-10-24 16:26:39 EDT
Should be in rawhide tomorrow

Note You need to log in before you can comment on or make changes to this bug.