Bug 171244 - anaconda exception dialog text rendering problem, crash with X error
anaconda exception dialog text rendering problem, crash with X error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-19 17:18 EDT by Charles R. Anderson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 15:34:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda dump (774.29 KB, text/plain)
2005-10-19 17:18 EDT, Charles R. Anderson
no flags Details

  None (edit)
Description Charles R. Anderson 2005-10-19 17:18:36 EDT
Description of problem:

During an install after package selection an exception occurred.  The exception
dialog opened.  When scrolling through the exception text, some of the backtrace
text was rendered improperly, overlapping previous text on the same line.  Text
was selected with the mouse to perhaps fix the rendering issue.  Shortly
afterwards, an X error occurred.

Version-Release number of selected component (if applicable):

buildstamp 200510190515.i386

How reproducible:
always

Steps to Reproduce:
1. boot with "graphical askmethod".
2. HTTP install.
3. Create custom layout.
4. Format all existing partitions except /home (/, swap, /boot, no LVM).
5. Additionally select server-cfg, system-tools.
6. During "Checking dependencies" Exception Occurred dialog appears.
7. Click "Exception text" arrow and scroll through the text.
8. Scroll quickly by holding down the Page Down key.  You may need to
fiddle with various scrolling, left, right, up, down, etc.
9. Eventually, X will crash with an error.

Actual results:

The program 'anaconda' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadLength'.
  (Details: serial 291530 error_code 16 request_code 51 minor_code 0)
...
Comment 1 Charles R. Anderson 2005-10-19 17:18:37 EDT
Created attachment 120174 [details]
anaconda dump
Comment 2 Jeremy Katz 2005-10-20 16:44:26 EDT
The exception is due to lack of error handling.  The XError is far more puzzling...
Comment 3 Jeremy Katz 2006-01-31 15:34:20 EST
We think this should be fixed now

Note You need to log in before you can comment on or make changes to this bug.