Bug 1712602 - libtalloc fails to build with Python 3.8
Summary: libtalloc fails to build with Python 3.8
Keywords:
Status: CLOSED DUPLICATE of bug 1711638
Alias: None
Product: Fedora
Classification: Fedora
Component: libtalloc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Simo Sorce
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1711638
Blocks: PYTHON38
TreeView+ depends on / blocked
 
Reported: 2019-05-21 23:16 UTC by Miro Hrončok
Modified: 2019-05-24 09:46 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-24 09:46:16 UTC


Attachments (Terms of Use)
Full log from Copr (217.91 KB, text/plain)
2019-05-21 23:16 UTC, Miro Hrončok
no flags Details

Description Miro Hrončok 2019-05-21 23:16:20 UTC
Created attachment 1571750 [details]
Full log from Copr

libtalloc 2.1.16-1.fc31 fails to build with Python 3.8.0a4.

The immediate problem is the same as in bz1711638, but even if the same workaround is applied, I get:

[ 9/36] Processing pytalloc-util.vscript: ABI/pytalloc-util-2.0.6.sigs ABI/pytalloc-util-2.0.7.sigs ABI/pytalloc-util-2.0.8.sigs ABI/pytalloc-util-2.1.0.sigs ABI/pytalloc-util-2.1.1.sigs ABI/pytalloc-util-2.1.2.sigs ABI/pytalloc-util-2.1.3.sigs ABI/pytalloc-util-2.1.4.sigs ABI/pytalloc-util-2.1.5.sigs ABI/pytalloc-util-2.1.6.sigs ABI/pytalloc-util-2.1.7.sigs ABI/pytalloc-util-2.1.8.sigs ABI/pytalloc-util-2.1.9.sigs ABI/pytalloc-util-2.1.10.sigs ABI/pytalloc-util-2.1.11.sigs ABI/pytalloc-util-2.1.12.sigs ABI/pytalloc-util-2.1.13.sigs ABI/pytalloc-util-2.1.14.sigs ABI/pytalloc-util-2.1.15.sigs ABI/pytalloc-util-2.1.16.sigs -> bin/default/pytalloc-util.vscript
[10/36] Compiling pytalloc-util.pc.in
[11/36] Compiling talloc.c
23:01:31 runner ['/usr/bin/gcc', '-O2', '-g', '-pipe', '-Wall', '-Werror=format-security', '-Wp,-D_FORTIFY_SOURCE=2', '-Wp,-D_GLIBCXX_ASSERTIONS', '-fexceptions', '-fstack-protector-strong', '-grecord-gcc-switches', '-specs=/usr/lib/rpm/redhat/redhat-hardened-cc1', '-specs=/usr/lib/rpm/redhat/redhat-annobin-cc1', '-m64', '-mtune=generic', '-fasynchronous-unwind-tables', '-fstack-clash-protection', '-fcf-protection', '-MMD', '-D_GNU_SOURCE=1', '-D_XOPEN_SOURCE_EXTENDED=1', '-fPIC', '-D__STDC_WANT_LIB_EXT1__=1', '-fstack-protector-strong', '-fstack-clash-protection', '-fvisibility=hidden', '-DSTATIC_talloc_MODULES=NULL', '-DSTATIC_talloc_MODULES_PROTO=extern void __talloc_dummy_module_proto(void)', '-I.', '-I../..', '-I.', '-I../..', '-Ilib/replace', '-I../../lib/replace', '-DHAVE_PYEXT=1', '-DHAVE_PYTHON_H=1', '../../talloc.c', '-c', '-o/builddir/build/BUILD/talloc-2.1.16/bin/default/talloc.c.5.o']
[12/36] Compiling pytalloc_util.c
23:01:31 runner ['/usr/bin/gcc', '-O2', '-g', '-pipe', '-Wall', '-Werror=format-security', '-Wp,-D_FORTIFY_SOURCE=2', '-Wp,-D_GLIBCXX_ASSERTIONS', '-fexceptions', '-fstack-protector-strong', '-grecord-gcc-switches', '-specs=/usr/lib/rpm/redhat/redhat-hardened-cc1', '-specs=/usr/lib/rpm/redhat/redhat-annobin-cc1', '-m64', '-mtune=generic', '-fasynchronous-unwind-tables', '-fstack-clash-protection', '-fcf-protection', '-MMD', '-D_GNU_SOURCE=1', '-D_XOPEN_SOURCE_EXTENDED=1', '-fPIC', '-D__STDC_WANT_LIB_EXT1__=1', '-fstack-protector-strong', '-fstack-clash-protection', '-fvisibility=hidden', '-I.', '-I../..', '-I.', '-I../..', '-Ilib/replace', '-I../../lib/replace', '-DHAVE_PYEXT=1', '-DHAVE_PYTHON_H=1', '../../pytalloc_util.c', '-c', '-o/builddir/build/BUILD/talloc-2.1.16/bin/default/pytalloc_util.c.13.o']
../../pytalloc_util.c:20:10: fatal error: Python.h: No such file or directory
   20 | #include <Python.h>
      |          ^~~~~~~~~~
compilation terminated.

Full log attached.

Comment 1 Lukas Slebodnik 2019-05-22 08:38:07 UTC
I explained the reason in different BZ
https://bugzilla.redhat.com/show_bug.cgi?id=1711638#c17

Comment 2 Miro Hrončok 2019-05-24 09:46:16 UTC

*** This bug has been marked as a duplicate of bug 1711638 ***


Note You need to log in before you can comment on or make changes to this bug.