Bug 171262 - Please disable the request for bug reports from FC builds of OOo software
Please disable the request for bug reports from FC builds of OOo software
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-19 22:16 EDT by Bob Kline
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.0-3.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-25 03:42:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Kline 2005-10-19 22:16:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
The other day while I was running oocalc in the FC4 distribution of the OpenOffice.org suite the program crashed and a dialog message came up stating that "OOo has crashed ..." and requesting that I send a bug report with the displayed information.  Assuming that the request was from the OpenOffice.org team, I filed a bug report with them, taking the time to provide a substantial amount of supporting information.  I received back a terse request that I file bug reports against the latest beta code, not the production version of the software I am running.  When I wrote back to point out that I wasn't a beta tester, and that I had only filed a bug report because they had asked me to, they got a little snotty and wrote back that it wasn't their software that had crashed, and made it very clear that they don't want bug reports for derived versions of their software which they didn't build themselves.  I wrote back and apologized for having bothered them, thinking that the dialog box requesting the bug report had been put up by the OOo team, rather than the Fedora team, and I promised that I would pass along to the Fedora team a suggestion that your build should not be requesting bug reports for builds of OOo created by the Fedora team.  So I posted a note to this effect on redhat.com's fedora-list, and I was asked if I would file an issue here ("The popup you saw should arguably be disabled in the FC build.").  So that's what I'm doing.

Bob Kline

(Yes, I know it doesn't make any sense for developers to turn down carefully prepared feedback on problems in their software, no matter where it's built.  I'm just passing on what I was told by the OOo team.  Sorry!)

Version-Release number of selected component (if applicable):
openoffice.org-core-1.9.125-1.1.0.fc4

How reproducible:
Always

Steps to Reproduce:
1. Do something which causes OOo to crash under FC4
2. Read the request to file a bug report
3. File the bug report
4. Read the nasty reply from the OOo team

Actual Results:  I got back a clear message that the OOo team didn't want any feedback on the FC builds of their software.

Expected Results:  In an ideal world, the OOo developers would welcome carefully assembled feedback on their software from any quarter.  I know I always do.  Obviously this isn't an ideal world, so it would probably best to suppress the request to file bug reports against the FC builds of OOo software.

Additional info:
Comment 1 Caolan McNamara 2005-10-20 02:58:42 EDT
*sigh*, it's a little silly. Though to be fair the fc4 beta is an old one. FC4
is to be updated to the 2.0.0 version as soon as it comes out, and with an
alternative crash screen. So this will be taken care of soon. Done in rawhide
version to be pushed for fc4 within a few days.

Note You need to log in before you can comment on or make changes to this bug.