Bug 1712697 - Different indentation used when describe node
Summary: Different indentation used when describe node
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.3.0
Assignee: Sally
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-22 06:06 UTC by Liang Xia
Modified: 2020-01-23 11:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:03:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:03:57 UTC

Description Liang Xia 2019-05-22 06:06:03 UTC
Description of problem:
Check the output of command "oc describe node",
some indentation with one space, while others use two spaces.


Version-Release number of selected component (if applicable):
openshift-clients-4.1.0-201905191700.git.0.cb455d6.el7.x86_64
Client Version: version.Info{Major:"4", Minor:"1+", GitVersion:"v4.1.0", GitCommit:"cb455d664", GitTreeState:"clean", BuildDate:"2019-05-19T21:13:58Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"linux/amd64"}
Server Version: version.Info{Major:"1", Minor:"13+", GitVersion:"v1.13.4+838b4fa", GitCommit:"838b4fa", GitTreeState:"clean", BuildDate:"2019-05-19T23:51:04Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"linux/amd64"}


How reproducible:
Always

Steps to Reproduce:
1. oc describe node xxx


Actual results:
$ oc describe node mynode
...
Conditions:
  Type             Status
  ----             ------
  MemoryPressure   False
  DiskPressure     False
  PIDPressure      False
  Ready            True
Addresses:
  InternalIP:  10.1.8.73
  Hostname:    dell-r730-063.dsal.lab.eng.rdu2.redhat.com
Capacity:
 cpu:            20
 hugepages-1Gi:  0
 hugepages-2Mi:  0


Expected results:
Both indentation with two spaces.

Comment 3 zhou ying 2019-10-25 08:21:44 UTC
We still could reproduce the issue with latest version:
[root@192 home]# oc version -o yaml 
clientVersion:
  buildDate: "2019-10-24T14:01:53Z"
  compiler: gc
  gitCommit: 118066a57f6280d685153dc0253ca2eb1fdc2333
  gitTreeState: clean
  gitVersion: v4.3.0
  goVersion: go1.12.8
  major: ""
  minor: ""
  platform: linux/amd64
openshiftVersion: 4.3.0-0.nightly-2019-10-25-015726


[root@192 home]# oc describe node ip-10-0-138-132.ap-northeast-1.compute.internal
....
CreationTimestamp:  Fri, 25 Oct 2019 11:28:05 +0800
Taints:             <none>
Unschedulable:      false
Conditions:
  Type             Status  LastHeartbeatTime                 LastTransitionTime                Reason                       Message
  ----             ------  -----------------                 ------------------                ------                       -------
  MemoryPressure   False   Fri, 25 Oct 2019 15:59:06 +0800   Fri, 25 Oct 2019 11:28:05 +0800   KubeletHasSufficientMemory   kubelet has sufficient memory available
  DiskPressure     False   Fri, 25 Oct 2019 15:59:06 +0800   Fri, 25 Oct 2019 11:28:05 +0800   KubeletHasNoDiskPressure     kubelet has no disk pressure
  PIDPressure      False   Fri, 25 Oct 2019 15:59:06 +0800   Fri, 25 Oct 2019 11:28:05 +0800   KubeletHasSufficientPID      kubelet has sufficient PID available
  Ready            True    Fri, 25 Oct 2019 15:59:06 +0800   Fri, 25 Oct 2019 11:29:26 +0800   KubeletReady                 kubelet is posting ready status
Addresses:
  InternalIP:   10.0.138.132
  Hostname:     ip-10-0-138-132.ap-northeast-1.compute.internal
  InternalDNS:  ip-10-0-138-132.ap-northeast-1.compute.internal
Capacity:
 attachable-volumes-aws-ebs:  39
 cpu:                         2
 ephemeral-storage:           125293548Ki
 hugepages-1Gi:               0
 hugepages-2Mi:               0
 memory:                      8161840Ki
 pods:                        250
Allocatable:
 attachable-volumes-aws-ebs:  39
 cpu:                         1500m
 ephemeral-storage:           115470533646
 hugepages-1Gi:               0
 hugepages-2Mi:               0
 memory:                      7547440Ki
 pods:                        250
System Info:
 Machine ID:                              d484c8d912524c8192541ffb6d7eedaf
 System UUID:                             ec2db4a8-e9a1-b259-382a-f0c65426c02e

Comment 4 Sally 2019-10-31 15:30:27 UTC
The upstream change didn't make it to oc yet, PR is here for kubernetes-kubectl: https://github.com/openshift/kubernetes-kubectl/pull/4  then will bump oc to bring this in. I'll report back when those are merged, thanks

Comment 5 Sally 2019-11-04 15:24:21 UTC
This PR will bring in the fix: https://github.com/openshift/oc/pull/144

Comment 7 zhou ying 2019-11-07 09:27:57 UTC
Confirmed with latest oc client, the issue has fixed:
[root@preserver-workloadrhel-1 ~]#  oc version
Client Version: v4.3.0


[root@preserver-workloadrhel-1 ~]# oc describe node ip-10-0-52-159.us-east-2.compute.internal
.....
Unschedulable:      false
Conditions:
  Type             Status  LastHeartbeatTime                 LastTransitionTime                Reason                       Message
  ----             ------  -----------------                 ------------------                ------                       -------
  MemoryPressure   False   Thu, 07 Nov 2019 04:25:43 -0500   Wed, 06 Nov 2019 04:23:49 -0500   KubeletHasSufficientMemory   kubelet has sufficient memory available
  DiskPressure     False   Thu, 07 Nov 2019 04:25:43 -0500   Wed, 06 Nov 2019 04:23:49 -0500   KubeletHasNoDiskPressure     kubelet has no disk pressure
  PIDPressure      False   Thu, 07 Nov 2019 04:25:43 -0500   Wed, 06 Nov 2019 04:23:49 -0500   KubeletHasSufficientPID      kubelet has sufficient PID available
  Ready            True    Thu, 07 Nov 2019 04:25:43 -0500   Wed, 06 Nov 2019 04:25:10 -0500   KubeletReady                 kubelet is posting ready status
Addresses:
  InternalIP:   10.0.52.159
  Hostname:     ip-10-0-52-159.us-east-2.compute.internal
  InternalDNS:  ip-10-0-52-159.us-east-2.compute.internal
Capacity:
  attachable-volumes-aws-ebs:  39
  cpu:                         4
  ephemeral-storage:           125293548Ki
  hugepages-1Gi:               0
  hugepages-2Mi:               0
  memory:                      16419376Ki
  pods:                        250
Allocatable:
  attachable-volumes-aws-ebs:  39
  cpu:                         3500m
  ephemeral-storage:           115470533646
  hugepages-1Gi:               0
  hugepages-2Mi:               0
  memory:                      15804976Ki
  pods:                        250
System Info:
  Machine ID:                                 b8393846100f41c2810462315c9d9ffd
  System UUID:                                ec2300c4-29a9-6507-06e4-8ee5a55c4f94
  Boot ID:                                    46ec1439-9427-4be1-bb5f-e446428e7407
  Kernel Version:                             4.18.0-147.el8.x86_64
  OS Image:                                   Red Hat Enterprise Linux CoreOS 43.81.201911011823.0 (Ootpa)
  Operating System:                           linux
  Architecture:                               amd64
  Container Runtime Version:                  cri-o://1.16.0-0.4.dev.rhaos4.3.giteed6aa1.el8-rc2
  Kubelet Version:                            v1.16.2
  Kube-Proxy Version:                         v1.16.2

Comment 9 errata-xmlrpc 2020-01-23 11:03:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.