Bug 171271 - ldap does not start after power failure
ldap does not start after power failure
Status: CLOSED DUPLICATE of bug 171272
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
4
All Linux
medium Severity low
: ---
: ---
Assigned To: Jay Fenlason
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-20 03:59 EDT by Alexey Baj
Modified: 2014-08-31 19:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-20 04:06:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey Baj 2005-10-20 03:59:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.2 (like Gecko)

Description of problem:
After power failure there is a high probability that ldap startup script would  
hang or would fail but report success. To make it start again one has to  
either recreate databases or run db_recover -h /var/lib/ldap, THEN run  
slaptest as user ldap.  

Version-Release number of selected component (if applicable):
openldap-servers-2.2.23-5

How reproducible:
Sometimes

Steps to Reproduce:
1. start slapd   
2. press 'reset'   
3. boot computer again  
      

Actual Results:  boot process hangs on "Starting slapd"   
or  . 
"Starting slapd [ OK ]", but slapd is not running. 

Expected Results:  At very least, init script should not block booting, and report failure if 
slapd fails to start. 
 
Maybe good thing is to run db_recovery each time slapd starts. 

Additional info:

When one manually runs db_recover $PATH_TO_LDAP_DB, then /sbin/service ldap 
start, in $PATH_TO_LDAP_DB files __db.* will be created with root permissions, 
and slapd would still not run. Cause is slaptest in init script.
Comment 1 Ignacio Vazquez-Abrams 2005-10-20 04:06:07 EDT

*** This bug has been marked as a duplicate of 171272 ***

Note You need to log in before you can comment on or make changes to this bug.