Bug 171303 - mplayer can't stop gnome-screensaver from kicking in
mplayer can't stop gnome-screensaver from kicking in
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-20 11:59 EDT by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 01:54:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2005-10-20 11:59:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8b5) Gecko/20051008 Fedora/1.5-0.5.0.beta2 Firefox/1.4.1

Description of problem:
mplayer (and probably several other media players) has a feature that enables it to disable the screensaver while it's running.  This is quite convenient to watch movies on the computer.

Ever since I switched to gnome-screensaver, this has no longer worked.  mplayer -stop-xscreensaver ... says it can't disable the screen saver.  Presumably it uses xscreensaver-command to tell the screen saver to stop and later restart, but since gnome-screensaver is a different screen saver, that doesn't quite work.  It would be nice of gnome-screensaver could accept commands from xscreensaver-command, and/or xscreensaver-command was extended to support xscreensaver.  Otherwise, it will require every application to support both.

Version-Release number of selected component (if applicable):
gnome-screensaver-0.0.16-1

How reproducible:
Always

Steps to Reproduce:
1.Run mplayer -stop-xscreensaver, or any scrip that used xscreensaver-command to keep the screensaver from kicking in during a movie, a presentation, whatever

Actual Results:  xscreensaver-command fails because it can't command gnome-screensaver

Expected Results:  It would be nice if it did

Additional info:
Comment 1 Marius Andreiana 2005-11-02 07:09:07 EST
Perhaps gnome-screensaver package should conflict with xscreensaver package, and
provide a symlink and similar functionality to xscreensaver-command
Comment 2 Alexandre Oliva 2005-11-03 11:20:24 EST
Core packages must not conflict with other core packages.  We need some
alternatives-based solution, or get xscreensaver-command clever enough to
command gnome-screensaver too.
Comment 3 Matthias Clasen 2006-08-04 01:54:50 EDT
gnome-screensaver has a well-defined and documented interface for inhibiting it.
mplayer just needs to use it.

Note You need to log in before you can comment on or make changes to this bug.