Bug 1713098 - [4.1.z] "server returned HTTP status 500 Internal Server Error" for some kubelet endpoints
Summary: [4.1.z] "server returned HTTP status 500 Internal Server Error" for some kube...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.z
Assignee: Ryan Phillips
QA Contact: Junqi Zhao
URL:
Whiteboard: 4.1.2
: 1716914 (view as bug list)
Depends On: 1712645
Blocks: 1718956
TreeView+ depends on / blocked
 
Reported: 2019-05-22 21:09 UTC by Seth Jennings
Modified: 2019-06-19 06:45 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1712645
Environment:
Last Closed: 2019-06-19 06:45:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift prometheus-client_golang pull 2 0 None None None 2019-06-05 14:10:35 UTC
Red Hat Product Errata RHBA-2019:1382 0 None None None 2019-06-19 06:45:44 UTC

Comment 1 Seth Jennings 2019-05-22 21:10:18 UTC
For backporting to 4.1.z

Comment 2 Ryan Phillips 2019-05-23 15:46:57 UTC
PR: https://github.com/openshift/origin/pull/22890

Comment 4 Junqi Zhao 2019-06-04 02:06:16 UTC
change back to MODIFIED, no 4.1.z OCP build package the fix to verify

Comment 5 Seth Jennings 2019-06-04 17:39:13 UTC
We also need https://github.com/prometheus/client_golang/pull/513 in 4.1.z

Comment 6 Seth Jennings 2019-06-04 17:39:40 UTC
*** Bug 1716914 has been marked as a duplicate of this bug. ***

Comment 7 Sudha Ponnaganti 2019-06-05 14:00:25 UTC
Can this wait for 4.1.2 or 4.2? or do we need it for 4.1.1?

Comment 8 W. Trevor King 2019-06-05 14:10:35 UTC
Backport: https://github.com/openshift/prometheus-client_golang/pull/2

Comment 10 Seth Jennings 2019-06-05 16:43:52 UTC
We need to bump this in origin/release-4.1.  The origin PR is the threshold for MODIFIED.
https://github.com/openshift/origin/pull/23035

Comment 11 Ryan Phillips 2019-06-05 20:21:36 UTC
PR merged within Origin.

Comment 12 W. Trevor King 2019-06-05 23:10:50 UTC
The Origin PR seems to have missed https://openshift-release.svc.ci.openshift.org/releasestream/4.1.0-0.nightly/release/4.1.0-0.nightly-2019-06-05-223716?from=4.1.0 , so this shouldn't move to ON_QA yet.

Comment 14 Junqi Zhao 2019-06-06 01:21:49 UTC
Based on Comment 12, move back to MODIFIED

Comment 15 Wei Sun 2019-06-06 02:07:57 UTC
Looks like the PR https://github.com/openshift/origin/pull/23035 is merged to 4.1.0-0.nightly-2019-06-05-233256 , please check this bug.

Comment 16 Junqi Zhao 2019-06-06 03:27:22 UTC
issue is fixed with 4.1.0-0.nightly-2019-06-05-233256

Comment 19 errata-xmlrpc 2019-06-19 06:45:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1382


Note You need to log in before you can comment on or make changes to this bug.