Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira ( If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1713103 - Unable to do image based provisioning with Cloud Init and VMware
Summary: Unable to do image based provisioning with Cloud Init and VMware
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Compute Resources - VMWare
Version: 6.6.0
Hardware: x86_64
OS: Linux
Target Milestone: 6.6.0
Assignee: Lukas Zapletal
QA Contact: Sanket Jagtap
Depends On:
TreeView+ depends on / blocked
Reported: 2019-05-22 21:20 UTC by Chris Roberts
Modified: 2019-11-07 12:07 UTC (History)
11 users (show)

Fixed In Version: foreman-proxy-,foreman-
Doc Type: Release Note
Doc Text:
The schema (HTTP/HTTPS) of `unattended_url` setting now affects if the provisioning templates are available through HTTP. Please check if you are not specifying the url with HTTPS schema, but using HTTP to get provisioning/userdata templates, this is unsupported behaviour as of Satellite 6.6.
Clone Of:
Last Closed: 2019-10-22 12:47:30 UTC
Target Upstream Version:

Attachments (Terms of Use)

System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:3172 0 None None None 2019-10-22 12:47:40 UTC

Description Chris Roberts 2019-05-22 21:20:25 UTC
Description of problem:

Following this guide:

We are unable to fetch the `<fqdn_foreman>/userdata/meta-data` because of HTTPS, if I turn off SSL on Foreman this works correctly. 

This worked fine on 6.3

Version-Release number of selected component (if applicable):

Katello 3.11
Foreman 1.21
vCenter 6.7

How reproducible:

Steps to Reproduce:

1. Install Katello 3.11
2. Setup Compute resource for VMware
3. Create a RHEL 7 template with cloud-init
4. Follow

Actual results:

Host builds and gets hostname correctly but does not do anything that it was instructed to with cloud-init, also in the Foreman UI it shows that the build is pending and since cloud-init can not pull down the metadata it never phones home to Foreman.

Expected results:

Build to finish correctly and UI to change from pending install to finished without having to turn off SSL.

Additional info:

It looks like here in the plugin we ignore HSTS:

I tried turning off HSTS both with the installer and in the /etc/foreman/settings.yml and that did not appear to fix the issue.

It looks like we force SSL here:

We can see from the cloud-init logs on a client we are getting redirected because of https:

Since we don't have the SSL CA we get a verify fail

I turned off https on Foreman with

Now we can see from a new client that we can curl the meta-data and the logs look good

[root@tonya-dunkel ~]# curl
instance-id: i-c1dfd96eea8cc2b627
mac: 00:50:56:9e:63:06

Foreman Userdata Templates is now part of Foreman 1.23 so this might work with latest upstream since it is part of core

Comment 10 Lukas Zapletal 2019-07-04 11:17:23 UTC
QA: Please follow this older tutorial on settings things up:

Process will be very similar if not the same, except there is no need of installing any plugin - all code is now part of Foreman core. Templates are also available.

Comment 11 Sanket Jagtap 2019-07-17 08:43:07 UTC
Build : Satellite 6.6 snap 11

I was able to provision and install the Vm on VMware with cloud init successfully following the above blogpost

2019-07-17 08:40:00,099 -[DEBUG]: [0/11] open 'http://sat-host/unattended/built?token=5398f5ce-95ab-4ee9-ac04-881dc4d3e24d' with {'url': 'http://sat-host/unattended/built?token=5398f5ce-95ab-4ee9-ac04-881dc4d3e24d', 'headers': {'User-Agent': 'Cloud-Init/18.2'}, 'allow_redirects': True, 'method': 'GET', 'timeout': 5.0} configuration
2019-07-17 08:40:01,201 -[DEBUG]: Read from http://sat-host/unattended/built?token=5398f5ce-95ab-4ee9-ac04-881dc4d3e24d (201, 0b) after 1 attempts
2019-07-17 08:40:01,202 -[DEBUG]: finish: modules-final/config-phone-home: SUCCESS: config-phone-home ran successfully
2019-07-17 08:40:01,202 -[DEBUG]: Ran 5 modules with 0 failures

Comment 13 errata-xmlrpc 2019-10-22 12:47:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.