Bug 1713193 - Overlap on Pod list page
Summary: Overlap on Pod list page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.3.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-23 06:23 UTC by Yadan Pei
Modified: 2020-01-23 11:04 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, long node names could overflow the table column in the OpenShift console pods table. Now they correctly wrap.
Clone Of:
Environment:
Last Closed: 2020-01-23 11:04:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
NoramlUserOnBareMetal (423.07 KB, image/png)
2019-05-23 06:24 UTC, Yadan Pei
no flags Details
NormalUserOnAWS (394.37 KB, image/png)
2019-05-23 06:25 UTC, Yadan Pei
no flags Details
KubeadminOnBareMetal (454.02 KB, image/png)
2019-05-23 06:27 UTC, Yadan Pei
no flags Details
4.2baremetal-normal-user (154.45 KB, image/png)
2019-06-26 07:33 UTC, Yanping Zhang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3363 'None' 'closed' 'Bug 1713193: Fix node wrapping in pod list' 2019-11-18 01:33:01 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:04:41 UTC

Description Yadan Pei 2019-05-23 06:23:57 UTC
Description of problem:
On Pod lists page, there is overlap between Node and Status column, reproduce on beremetal env and only normal user reproduces this issue.

Version-Release number of selected component (if applicable):
4.1.0-0.nightly-2019-05-22-190823
console image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:e6b3e376fd5e0e69d65d12f75e349691e21b155b196618dcbfc3cd9865c343cf
console commit: https://github.com/openshift/console/commit/d8fc460a3d0e9f8de3d14373de8f36ba09103537

How reproducible:
Always on baremetal env

Steps to Reproduce:
1. Create applications and goes to Workloads -> Pods page
Actual results:
1. All pods are listed in the table with Node and Status column.


Expected results:
1. Node and Status data should be shown correctly

Additional info:
On the clusters setup on AWS, the issue is not reproduced although node such as `ip-10-0-153-65.us-east-2.compute.internal`  has the same length with baremetal node name such as `dell-r730-067.dsal.lab.eng.rdu2.redhat.com`

Only normal user reproduces this issue and I guess that it should be format issue after disabling node link for normal user

Comment 1 Yadan Pei 2019-05-23 06:24:43 UTC
Created attachment 1572352 [details]
NoramlUserOnBareMetal

Comment 2 Yadan Pei 2019-05-23 06:25:25 UTC
Created attachment 1572353 [details]
NormalUserOnAWS

Comment 3 Yadan Pei 2019-05-23 06:27:38 UTC
Created attachment 1572354 [details]
KubeadminOnBareMetal

Comment 4 Samuel Padgett 2019-05-23 13:14:21 UTC
https://github.com/openshift/console/pull/1607

Comment 6 Yanping Zhang 2019-06-26 07:33:06 UTC
Created attachment 1584639 [details]
4.2baremetal-normal-user

Comment 7 Yanping Zhang 2019-06-26 07:33:43 UTC
build: 4.2.0-0.nightly-2019-06-25-222454
console commit: 585dfbf26db35b5d566a20228fbe071de78b9f22
Checked on ocp 4.2 env with above version, the bug still could be reproduced on baremetal env by normal user.

Comment 11 Yadan Pei 2019-11-15 09:18:27 UTC
Don't have a cluster with long node name, will check when there's

Comment 12 Yadan Pei 2019-11-18 09:51:00 UTC
Normal user don't see this issue when node name is 41 chars long

Will continue to track the issue on other type of clusters 

Verified on 4.3.0-0.nightly-2019-11-17-224250

Comment 14 errata-xmlrpc 2020-01-23 11:04:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.