Bug 17132 - installer crashes if you go back to change the partition sizes
Summary: installer crashes if you go back to change the partition sizes
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brock Organ
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-31 14:51 UTC by Giuseppe Raimondi
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-29 19:13:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Giuseppe Raimondi 2000-08-31 14:51:59 UTC
I was trying an installation (text expert) and had to change the partition
sizes, so I went back to disk druid to do it and when I arrived again at
the installation of the packages the installer gave me a warning, saying:
"the kernel is unable to read your new partitioning information, probably
because you modified extended partitions.....etc" also stating this is not
critical and just need to reboot. I only could select ok and then I had a
message "excepton occurred"
Traceback (innermost last) File "/usr/bin/anaconda", line ...
intf.run(todo, test = test)
and so on
File "/usr/lib/anaconda/todo.py", line ..., in doInstall
self.fstab.savePartitions ()
File "/usr/lib/anaconda/fstab.py", line ..., in savePartitions
self.druid.save ()
name error: sys

I had the same with the 6.2 installer, apart from the nice error message
before.

Comment 1 Michael Fulbright 2000-09-07 20:46:23 UTC
Please reproduce Brock.

Comment 2 Michael Fulbright 2000-09-29 19:13:18 UTC
I have fixed this in the internal development tree.


Note You need to log in before you can comment on or make changes to this bug.