Bug 1713211 - Stateful set donut does not update on overview when stateful set is scaled
Summary: Stateful set donut does not update on overview when stateful set is scaled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.11.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-23 07:37 UTC by Ian Lawson
Modified: 2019-06-26 09:08 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the web console could show an incorrect "Scaling to..." value for stateful sets in the project overview under some conditions. The stateful set desired replicas value now correctly updates in the web console project overview.
Clone Of:
Environment:
Last Closed: 2019-06-26 09:08:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
UI scaling *down* to 0, reporting 'scaling to 4' incorrectly (890.85 KB, image/png)
2019-05-23 07:37 UTC, Ian Lawson
no flags Details
Screenshot showing the statefulset scaled to 0 and the UI displaying 'Scaling to 4' (892.11 KB, image/jpeg)
2019-05-31 10:27 UTC, Ian Lawson
no flags Details
This is working, donut replicas number is soon updated to 0 (16.80 KB, image/png)
2019-06-14 08:32 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1605 None None None 2019-06-26 09:08:20 UTC

Description Ian Lawson 2019-05-23 07:37:47 UTC
Created attachment 1572382 [details]
UI scaling *down* to 0, reporting 'scaling to 4' incorrectly

Description of problem:

When using an operator to scale pods up and down the information message within the Pod circle is invalid and not updated correctly. For instance, using the Infinispan Operator, I can install a CR with a Pod count of four. When I apply a change to that CR to reduce the Pod count to 0, and then rescale to 4 the message within reflects the *previous* event - i.e. when scaling up to 4 from 0 the message remains 'scaling to 0', even when the Pod scale-up has completed. This leads to some confusion from the user perspective, as, in the example given, the Pod count stabilises at 4 but the message remains 'scaling to 0', or in the case of downscaling to 0 the message remains 'scaling to 4'


Version-Release number of selected component (if applicable):

v3.11.88

How reproducible:

Always - using the Infinispan Operator at https://github.com/infinispan/infinispan-simple-tutorials/tree/master/operator and the following two CR definitions:

(Scale to four)

apiVersion: infinispan.org/v1
kind: Infinispan
metadata:
  name: example-infinispan
spec:
  size: 4
  clustername: uthcluster2

(Scale to zero)

apiVersion: infinispan.org/v1
kind: Infinispan
metadata:
  name: example-infinispan
spec:
  size: 0
  clustername: uthemptycluster


Steps to Reproduce:
1. Install the Infinispan Operator as defined in the README.md at the provided git repo
2. Apply the (scale to 4) CR using 'oc apply -f (four node yaml filename)
3. Apply the (scale to 0) CR using 'oc apply -f (zero node yaml) filename
4. Watch the Overview page

Actual results:

Pods scale to count 4 *but* the message 'Scaling to 0' remains in the middle of the Pod graphic


Expected results:

'Scaling to x' should disappear when the Pod count reaches the appropriate level and should reflect the actual count required (i.e. when scaling to 4 the message should read 'scaling to 4'.


Additional info:

Only seems to be a side-effect of a change of stateful set replica count

Comment 2 Ian Lawson 2019-05-24 09:40:24 UTC
Mentioned above, 3.11.88 build is where I'm seeing this.....

Comment 3 Tim Bielawa 2019-05-24 16:48:42 UTC
(In reply to Ian Lawson from comment #2)
> Mentioned above, 3.11.88 build is where I'm seeing this.....

OK I see that but I don't know how that relates to the release team. We build and deliver the code. We don't debug and fix why pods aren't scaling. I think you need another team for this.

Comment 4 Ian Lawson 2019-05-28 06:06:53 UTC
(In reply to Tim Bielawa from comment #3)
> (In reply to Ian Lawson from comment #2)
> > Mentioned above, 3.11.88 build is where I'm seeing this.....
> 
> OK I see that but I don't know how that relates to the release team. We
> build and deliver the code. We don't debug and fix why pods aren't scaling.
> I think you need another team for this.

This is a code issue not a debug issue - the UI is not behaving as expected or intended, and the resulting information to the end user is confusing and incorrect. The event model in the UI isn't being called correctly when the scaling of the Pod changes *when* the Pod is a StatefulSet and not a DeploymentConfig.

It's a code issue in the UI - given this UI is effectively retired as of 3.11 I wouldn't normally raise it but a lot of customers will be sticking with 3.11 for a while *and* Operators are the key feature people will be using. Given the fact the Operators use StatefulSets for replication this issue will be seen a lot going forward.

Comment 5 Samuel Padgett 2019-05-30 19:25:12 UTC
The UI shows the value of `spec.replicas` in the center of the donut. Does the value displayed match what's in the stateful set?

$ oc get statefulset <my-stateful-set> -o jsonpath='{.spec.replicas}'

Console has no knowledge of Infinispan. Adding special support for Infinispan would be a separate RFE.

Comment 6 Ian Lawson 2019-05-31 10:26:34 UTC
I think the 'Infinispan' stuff is a red herring, that's just the CR/CRD consumed by the Operator.

I've checked the replica count in the example - it returns '0' as expected when I downscale the number, the UI displays 'Scaling to 4' in the Pod graphic as shown in attached file.....

Comment 7 Ian Lawson 2019-05-31 10:27:39 UTC
Created attachment 1575643 [details]
Screenshot showing the statefulset scaled to 0 and the UI displaying 'Scaling to 4'

Comment 10 XiaochuanWang 2019-06-14 08:31:24 UTC
This is fixed on the version:
OpenShift Web Console:    v3.11.117 

When the pods are scaling up to 10, then soon update the replicas to 0 (edit the yaml spec.replicas). The donut number is quickly updated to 0 with the notification message "Stateful Set example-ss was successfully updated."

Comment 11 XiaochuanWang 2019-06-14 08:32:41 UTC
Created attachment 1580597 [details]
This is working, donut replicas number is soon updated to 0

Comment 13 errata-xmlrpc 2019-06-26 09:08:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1605


Note You need to log in before you can comment on or make changes to this bug.