Bug 1713229 - Octavia tempest tests fail with "Provider 'octavia' is not enabled"
Summary: Octavia tempest tests fail with "Provider 'octavia' is not enabled"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: beta
: 15.0 (Stein)
Assignee: Carlos Goncalves
QA Contact: Bruna Bonguardo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-23 08:11 UTC by Carlos Goncalves
Modified: 2019-09-26 10:51 UTC (History)
4 users (show)

Fixed In Version: puppet-tripleo-10.4.2-0.20190623230404.53b3156.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:22:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 659532 0 None None None 2019-05-23 08:12:17 UTC
OpenStack gerrit 660511 0 None None None 2019-05-23 08:12:17 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:22:48 UTC

Description Carlos Goncalves 2019-05-23 08:11:01 UTC
Description of problem:

Many Octavia tempest tests fail because 'octavia' provider driver is not enabled by default in an OSP 15 ML2/OVN deployment. 

Version-Release number of selected component (if applicable):
OSP 15 pre-beta

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP 15 with ML2/OVN
2. Run Octavia tempest tests, for example octavia_tempest_plugin.tests.scenario.v2.test_l7rule.L7RuleScenarioTest
3. Test fails with "Provider 'octavia' is not enabled."

Actual results:

testtools.testresult.real._StringException: Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/tempest/test.py", line 173, in setUpClass
    six.reraise(etype, value, trace)
  File "/usr/lib/python3.6/site-packages/six.py", line 675, in reraise
    raise value
  File "/usr/lib/python3.6/site-packages/tempest/test.py", line 166, in setUpClass
    cls.resource_setup()
  File "/usr/lib/python3.6/site-packages/octavia_tempest_plugin/tests/scenario/v2/test_l7rule.py", line 51, in resource_setup
    lb = cls.mem_lb_client.create_loadbalancer(**lb_kwargs)
  File "/usr/lib/python3.6/site-packages/octavia_tempest_plugin/services/load_balancer/v2/loadbalancer_client.py", line 91, in create_loadbalancer
    return self._create_object(**kwargs)
  File "/usr/lib/python3.6/site-packages/octavia_tempest_plugin/services/load_balancer/v2/base_client.py", line 101, in _create_object
    response, body = self.post(request_uri, jsonutils.dumps(obj_dict))
  File "/usr/lib/python3.6/site-packages/tempest/lib/common/rest_client.py", line 283, in post
    return self.request('POST', url, extra_headers, headers, body, chunked)
  File "/usr/lib/python3.6/site-packages/tempest/lib/common/rest_client.py", line 679, in request
    self._error_checker(resp, resp_body)
  File "/usr/lib/python3.6/site-packages/tempest/lib/common/rest_client.py", line 790, in _error_checker
    raise exceptions.BadRequest(resp_body, resp=resp)
tempest.lib.exceptions.BadRequest: Bad request
Details: {'faultcode': 'Client', 'faultstring': "Provider 'octavia' is not enabled.", 'debuginfo': None}

Comment 6 Bruna Bonguardo 2019-07-30 12:55:32 UTC
I don't see the "Provider 'octavia' is not enabled" error message in any of the test results:

https://rhos-qe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/DFG-network-octavia-15_director-rhel-virthost-3cont_2comp-ipv4-geneve-ovn/39//artifact/tempest-results/tempest-results-octavia.1.html

(puddle RHOS_TRUNK-15.0-RHEL-8-20190725.n.1)


Moving the bug to VERIFIED.

Comment 10 errata-xmlrpc 2019-09-21 11:22:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.