Bug 1713289 - Octavia amphora certificate files in wrong path and with invalid content
Summary: Octavia amphora certificate files in wrong path and with invalid content
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: beta
: 15.0 (Stein)
Assignee: Carlos Goncalves
QA Contact: Bruna Bonguardo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-23 10:43 UTC by Carlos Goncalves
Modified: 2019-09-26 10:51 UTC (History)
2 users (show)

Fixed In Version: openstack-tripleo-common-10.7.1-0.20190625154433.5751fc7.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:22:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1830190 0 None None None 2019-05-23 10:46:54 UTC
OpenStack gerrit 660971 0 None MERGED Fix Octavia certificate file path and content 2020-04-24 02:39:43 UTC
OpenStack gerrit 661352 0 None MERGED Fix Octavia certificate file path and content 2020-04-24 02:39:44 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:22:48 UTC

Description Carlos Goncalves 2019-05-23 10:43:30 UTC
Description of problem:

Octavia amphora certificate files are being created in an unexpected path and with invalid content
[root@controller-2 log]# ls /var/lib/config-data/puppet-generated/ | grep octavia
octavia
octaviaca_cert_path
octaviaca_private_key_path
octaviaclient_cert_path
octavia.md5sum


[root@controller-2 log]# cat /var/lib/config-data/puppet-generated/octaviaca_cert_path
ca_cert_content[root@controller-2 log]# cat /var/lib/config-data/puppet-generated/octaviaca_private_key_path
private_key_content[root@controller-2 log]# cat /var/lib/config-data/puppet-generated/octaviaclient_cert_path
service_pem_content[root@controller-2 log]#

Version-Release number of selected component (if applicable):
RHOS_TRUNK-15.0-RHEL-8-20190520.n.2

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP 15 with Octavia enabled
2. Create amphora load balancer

Actual results:
Load balancer will not be created successfully. It will go into ERROR provisioning_status

Expected results:
Amphora load balancer would be successfully provisioned and go ACTIVE.

Comment 9 errata-xmlrpc 2019-09-21 11:22:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.