Bug 1713366 - IPA Web UI - Pagination is not working for the "Automount Maps" page.
Summary: IPA Web UI - Pagination is not working for the "Automount Maps" page.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: ipa
Version: 8.0
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: ipa-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-23 13:29 UTC by Têko Mihinto
Modified: 2019-11-05 20:53 UTC (History)
7 users (show)

Fixed In Version: ipa-4.8.0-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 20:53:20 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
autommou_map.jpg (109.02 KB, image/png)
2019-08-16 06:07 UTC, Mohammad Rizwan
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3348 None None None 2019-11-05 20:53:33 UTC

Description Têko Mihinto 2019-05-23 13:29:53 UTC
Description of problem:
The pagination is not working for data created in the Network Services / Automount page.

Version-Release number of selected component (if applicable):

# rpm -qa | grep ^ipa
ipa-common-4.6.4-10.el7_6.3.noarch
ipa-client-common-4.6.4-10.el7_6.3.noarch
ipa-server-4.6.4-10.el7_6.3.x86_64
ipa-server-common-4.6.4-10.el7_6.3.noarch
ipa-client-4.6.4-10.el7_6.3.x86_64
ipa-server-dns-4.6.4-10.el7_6.3.noarch
#

# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.6 (Maipo)
#


How reproducible:
Always.

Steps to Reproduce:
1. Create an automount location:

# ipa automountlocation-add test
----------------------------------
Added automount location "test"
----------------------------------
  Location: test
#

2. Add more automount maps than the pagination size ( can be configured by a click on the connected user and then "Customization" ).
For my tests, the pagination size is set to 10 and more than 1000 maps are created:

# export N=0
# while [ $N -lt 1000 ]
> do
> ipa automountmap-add test test_map_$N > /dev/null 2>&1
> N=`expr $N + 1`
> echo $N
> done
1
2
...
999
1000
#

3. Connect to the Web UI and access to the Network Services / Automount page.
All data will be listed on each page of the pagination.

Actual results:
All items are listed on each and every page.

Expected results:
The number of listed items should be limited by the configured pagination size.

Additional info:

Comment 3 Florence Blanc-Renaud 2019-05-24 12:39:38 UTC
Upstream ticket:
https://pagure.io/freeipa/issue/6627

Comment 4 Florence Blanc-Renaud 2019-06-19 07:41:14 UTC
RHEL-7.7 is already near the end of a Development Phase and development is being wrapped up. I am bulk-moving to RHEL 8 the Bugs which were already triaged, but to which we did not commit (without devel_ack) and we cannot keep them even as a stretch goal for RHEL-7.7.

If you believe this particular bug should be reconsidered for 7.7, please let us know.

Comment 8 Mohammad Rizwan 2019-08-16 06:05:35 UTC
version:
ipa-server-4.8.0-6.module+el8.1.0+3869+84a20141.x86_64

steps:
1. Create an automount location:

# ipa automountlocation-add test
----------------------------------
Added automount location "test"
----------------------------------
  Location: test
#

2. Add more automount maps than the pagination size ( can be configured by a click on the connected user and then "Customization" ).
For my tests, the pagination size is set to 10 and more than 1000 maps are created:

# export N=0
# while [ $N -lt 1000 ]
> do
> ipa automountmap-add test test_map_$N > /dev/null 2>&1
> N=`expr $N + 1`
> echo $N
> done
1
2
...
999
1000
#

3. Connect to the Web UI and access to the Network Services / Automount page.
All data will be listed on each page of the pagination.

Actual results:
Number of listed items are inline with the configured pagination setting.

Expected results:
The number of listed items should be limited by the configured pagination size.


Based on above observation, marking the bug as verified.

Comment 9 Mohammad Rizwan 2019-08-16 06:07:14 UTC
Created attachment 1604289 [details]
autommou_map.jpg

Comment 11 errata-xmlrpc 2019-11-05 20:53:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3348


Note You need to log in before you can comment on or make changes to this bug.