Bug 1713466 - need package for python-sqlalchemy-collectd
Summary: need package for python-sqlalchemy-collectd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-sqlalchemy-collectd
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: 15.0 (Stein)
Assignee: Michael Bayer
QA Contact: RHOS Maint
URL:
Whiteboard:
Depends On:
Blocks: 1717095
TreeView+ depends on / blocked
 
Reported: 2019-05-23 19:20 UTC by Michael Bayer
Modified: 2019-09-26 10:51 UTC (History)
3 users (show)

Fixed In Version: python-sqlalchemy-collectd-0.0.3-5.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1717095 (view as bug list)
Environment:
Last Closed: 2019-09-21 11:22:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 659678 0 None None None 2019-05-23 19:22:18 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:22:49 UTC

Description Michael Bayer 2019-05-23 19:20:25 UTC
in https://review.opendev.org/#/c/659678/ we'd like to add the python-sqlalchemy-collectd package to openstack containers, where it must be present both in the collectd container, as well as all the containers that extend from base openstack, any which include the python-sqlalchemy package.  This package is currently in Fedora at https://src.fedoraproject.org/rpms/python-sqlalchemy-collectd and named as a dep in RDO in https://github.com/redhat-openstack/rdoinfo/blob/master/deps.yml#L497.

Based on the conventions used it would need python3-sqlalchemy-collectd for rhel8 systems which I guess is what covers RHOS for 15/ 16.

Comment 1 Michael Bayer 2019-05-23 19:23:12 UTC
also let me know if this has to be two separate bz's for stein /train etc

Comment 2 Michael Bayer 2019-05-23 19:24:11 UTC
note also the above openstack gerrit is paused from merge until RHEL has the packages (also I'm not sure what we do on the centos side here)

Comment 4 Alfredo Moralejo 2019-06-04 17:08:35 UTC
(In reply to Michael Bayer from comment #2)
> note also the above openstack gerrit is paused from merge until RHEL has the
> packages (also I'm not sure what we do on the centos side here)

Note that upstream kolla and tripleo are using python2/CentOS7. RDO is already providing python2-sqlalchemy-collectd and it's being pulled in CI jobs for https://review.opendev.org/#/c/659678:

http://logs.openstack.org/78/659678/2/check/tripleo-build-containers-centos-7/6cb0e14/logs/build.log.txt.gz
http://logs.openstack.org/78/659678/2/check/kolla-build-centos-binary/44e7500/logs/build/openstack-base.txt.gz

Nothing else is needed in CentOS/RDO side.

Comment 5 Lon Hohberger 2019-06-04 17:31:43 UTC
Yeah, RDO is all set.

Comment 6 Michael Bayer 2019-06-07 19:34:22 UTC
so I might need to make a new BZ for this but in fedora I have 0.0.4 already built, but not in f30 yet: https://koji.fedoraproject.org/koji/buildinfo?buildID=1272864  does this have to be released in fedora first before I can rebuild in RHOS for 0.0.4 ?

Comment 13 errata-xmlrpc 2019-09-21 11:22:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.