Bug 1713620 - namespace should be openshift-etcd for "kube_pod_status_ready:etcd:sum" rule
Summary: namespace should be openshift-etcd for "kube_pod_status_ready:etcd:sum" rule
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.1.z
Assignee: Frederic Branczyk
QA Contact: Junqi Zhao
URL:
Whiteboard: 4.1.2
Depends On:
Blocks: 1718956
TreeView+ depends on / blocked
 
Reported: 2019-05-24 09:26 UTC by Junqi Zhao
Modified: 2019-06-19 06:45 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-19 06:45:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 357 0 None None None 2019-05-27 08:58:06 UTC
Github openshift cluster-monitoring-operator pull 360 0 None None None 2019-05-29 13:20:58 UTC
Red Hat Product Errata RHBA-2019:1382 0 None None None 2019-06-19 06:45:44 UTC

Description Junqi Zhao 2019-05-24 09:26:34 UTC
Description of problem:
etcd pods are deployed under openshift-etcd project now, not in kube-system
********************************************
# oc -n openshift-etcd  get pod
NAME                                                     READY   STATUS    RESTARTS   AGE
etcd-member-ip-10-0-135-140.us-east-2.compute.internal   2/2     Running   0          8h
etcd-member-ip-10-0-151-177.us-east-2.compute.internal   2/2     Running   0          8h
etcd-member-ip-10-0-169-0.us-east-2.compute.internal     2/2     Running   0          8h
********************************************
# oc -n kube-system  get pod
No resources found.
********************************************

but "kube_pod_status_ready:etcd:sum" rule still use "kube-system" project
********************************************
record: kube_pod_status_ready:etcd:sum 
expr: sum
  by(condition) (kube_pod_status_ready{condition="true",namespace="kube-system",pod=~"etcd.*"})
********************************************

Version-Release number of selected component (if applicable):
4.1.0-0.nightly-2019-05-23-213243

How reproducible:
Always

Steps to Reproduce:
1. Check "kube_pod_status_ready:etcd:sum" rule
2.
3.

Actual results:
namespace is stil "kube-system" for "kube_pod_status_ready:etcd:sum" rule

Expected results:
namespace should be openshift-etcd for "kube_pod_status_ready:etcd:sum" rule

Additional info:

Comment 2 Junqi Zhao 2019-06-04 01:33:06 UTC
change back to MODIFIED, no 4.1.z OCP build to verify now

Comment 4 Junqi Zhao 2019-06-05 03:18:38 UTC
namespace is openshift-etcd for "kube_pod_status_ready:etcd:sum" rule
payload: 4.1.0-0.nightly-2019-06-04-235906

Comment 6 errata-xmlrpc 2019-06-19 06:45:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1382


Note You need to log in before you can comment on or make changes to this bug.