Bug 1713656 - Open Java Console link disappeared in OpenShift web console
Summary: Open Java Console link disappeared in OpenShift web console
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Antonin Stefanutti
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1798694 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-24 12:15 UTC by mchoma
Modified: 2020-05-15 19:26 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-15 19:26:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Issue Tracker ENTESB-12193 Critical Closed Automatically create a ConsoleLink for the Fuse Console 2020-09-10 11:58:15 UTC

Description mchoma 2019-05-24 12:15:39 UTC
Description of problem:
I dont see "Open Java Console" link on OCP 4.1 web console as I was used to in OCP 3.11.

Customer Impact: Customer used to use "Open Java Console" in OpenShift web console for reading jmx values is not able to do so anymore. We are not aware of any workaround right now.

Feature JVM Console is documented in OCP 3.11 Documentation [2].
There is no deprecation note in 3.11 release notes [3].
Feature JVM Console is not documented in OCP 4.1 Documentation anymore [5].
We have just found this statement "Starting in 4.1 the Java console is no longer bundled with OpenShift console and is not installed by default." [4]

[2] https://docs.openshift.com/container-platform/3.11/architecture/infrastructure_components/web_console.html#jvm-console
[3] https://docs.openshift.com/container-platform/3.11/release_notes/ocp_3_11_release_notes.html
[4] https://bugzilla.redhat.com/show_bug.cgi?id=1680569#c3
[5] https://docs.openshift.com/container-platform/4.1/welcome/index.html


Version-Release number of selected component (if applicable):
4.1 rc5

How reproducible:
I have deployed EAP CD16 image. Basically I did this:
{code}
oc import-image jboss-eap-7-tech-preview/eap-cd-openshift --from=registry.access.redhat.com/jboss-eap-7-tech-preview/eap-cd-openshift --confirm
oc new-app eap-cd-openshift --name eap-app
{code}
and renamed port 8787 to "jolokia"
Looking into openshift web console at pod details I cant see that link.

Comment 7 Antonin Stefanutti 2019-07-25 12:44:28 UTC
The newest version of the Java Console will be delivered as part of the Fuse Console, which provide equivalent level of functionality, but with latest bug fixes, up-to-date PatternFly UI and Red Hat branding. 

The main work to have the Fuse Console working on OpenShift 4 has just been completed upstream [1]. Productisation will follow, so it should be available in the next Fuse release. In parallel, we are now working on making the new console available in OperatorHub, so it's easy for customers to install the new console, as a replacement for the Java Console that they were used to use in OpenShift 3.

Documentation about the new integration with OpenShift 4 can be found at [2].

[1]: https://github.com/hawtio/hawtio-online/pull/38

[2]: https://docs.google.com/document/d/1xCEFHKKayt06xktee_xcIHyU_5U7wj7exz9ZtEwGiDk

Comment 10 Antonin Stefanutti 2019-08-22 12:58:47 UTC
The community version of the Fuse Console (Hawtio Online [1]) is now available in OperatorHub [2]. It can be used as a replacement for the old JVM console, provided that the Jolokia agents must be updated to use:
- Use Jolokia 1.6.2
- Add the Fuse Console (Hawtio Online) principal to the list of authorised clients

The productised version is currently planned to be released with Fuse 7.5.

We plan to work the following improvements ASAP:
- Add menu link CRD
- Automate the client certificate generation in the console operator

[1]: https://github.com/hawtio/hawtio-online
[2]: https://github.com/operator-framework/community-operators/pull/592

Comment 16 Samuel Padgett 2020-02-05 21:16:59 UTC
*** Bug 1798694 has been marked as a duplicate of this bug. ***

Comment 18 bpeterse 2020-05-15 19:26:05 UTC
Closing this bug out as there is no console work to track.  The relevant console extension points are available for use by other components:
https://github.com/openshift/api/tree/master/console/v1


Note You need to log in before you can comment on or make changes to this bug.