Bug 171370 - Can't boot Kernel without modules support without initrd
Can't boot Kernel without modules support without initrd
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-21 05:40 EDT by Laurent PELLISSIER
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-16 09:50:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Laurent PELLISSIER 2005-10-21 05:40:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
I usually always use my own vanilla Kernel compiled without modules support. With RHEL 4 update 1. It doesn't boot without initrd. But initrd is used only with Kernel compiled with modules support.
There are 2 problems :

1/ Without using initrd, Kernel 2.6.13 boot fails because it can't open a console. The reason is that /dev/console (and others like /dev/tty, ...) doesn't exist. /dev is empty and is populated by udev later in the boot process. But the boot process is stopped before reaching udev. The solution is to boot with RHEL rescue CD and to copy /dev/* to /mnt/sysimage/dev. Now it's possible to boot my static Kernel without using a useless initrd

2/ If I'm trying to use the initrd files provided with RHEL (initrd-2.6-9-11.ELsmp.img yes my box has 2 CPUs) the boot fails because it can't insmod SCSI modules. If I delete the modules in the /lib directory of the img file and I remove the insmod in the init file the boot fails again because it can't mount root filesystem (mount error 6). Of course my Kernel is compiled with everything needed (ex2fs, initrd support, ...) and works fine without initrd (see 1/) and with my own initrd but not with the one provided with RHEL.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot with a kernel compiled without modules support and without initrd
2.
3.
  

Additional info:
Comment 1 Jason Baron 2005-12-16 09:50:16 EST
so you're trying to boot 2.6.13 with the rhel4 initrd and you want that to work?
If that's then i'd suggest simply not using it.
Comment 2 Laurent PELLISSIER 2005-12-16 10:12:11 EST
No as I explained I want to boot with a static kernel 2.6.13 compiled by myself.
But it fails if I don't tell it to use an initrd file. But initrd file is
useless for a staticly compiled kernel.

Note You need to log in before you can comment on or make changes to this bug.