Bug 171395 - Flawed package conflicts with Fedora Extras
Summary: Flawed package conflicts with Fedora Extras
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libsigc++   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-21 14:54 UTC by Michael Schwendt
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-26 11:53:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Schwendt 2005-10-21 14:54:56 UTC
On Wed, 19 Oct 2005 07:14:10 -0400, Build System wrote:

> New package libsigc++
> 	The Typesafe Signal Framework for C++.

> * Wed Oct 19 2005 Caolan McNamara <caolanm@redhat.com> 2.0.16-1
> - the return of libsigc++
> 
> * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
> - automated rebuild

https://www.redhat.com/archives/fedora-devel-list/2005-October/msg00245.html
https://www.redhat.com/archives/fedora-devel-list/2005-October/msg00257.html

This new package currently conflicts with libsigc++20 from Fedora
Extras, since it upgrades the older version for the older API which
we've kept in a package called libsigc++.

The package in Fedora Core Development is based on an old package from
Red Hat Linux, which has flaws. It owns /usr/share/doc, contains
libsigc-2.0.so in the wrong package, it contains duplicates of the
%doc files from the main package in the -devel package, it should
require pkgconfig in the -devel package, and it moves the html docs
to a different directory. A copy of the GPL ought to be included, btw.

Please don't ignore Fedora Extras like this.

Comment 1 Caolan McNamara 2005-10-26 11:53:00 UTC
package removed again from core. we got out wires a little crossed here.


Note You need to log in before you can comment on or make changes to this bug.