Bug 171410 - xmlsec1: omit /usr/lib/lib*.la, /usr/lib/lib*.a
xmlsec1: omit /usr/lib/lib*.la, /usr/lib/lib*.a
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xmlsec1 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-21 12:04 EDT by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.2.9-7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-08 09:39:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2005-10-21 12:04:42 EDT
Avoid libtool madness and omit libtool archives (/usr/lib/lib*.la) and static
libs (/usr/lib/lib*.a).

See bug #154142 as an example of the problems that can be avoided.
Comment 1 Daniel Veillard 2005-10-21 12:11:53 EDT
for .la, yes for .a no, I don't see the madness

Daniel
Comment 2 Rex Dieter 2005-10-21 12:22:12 EDT
If you remove the .la files, in general, it makes static libs (sometimes *very*)
difficult to use(*), that's all.  That's why I usually recommend to packagers
that if they insist on keeping .la files, they package them separately along
with the static libs.

(*) In this case, the .la libxmlsec1.la contains the dependant library
information, which is (usually) superluous in the shared library case, but
almost always required when linking statically.
Comment 3 Kjartan Maraas 2005-11-07 15:31:03 EST
Is this a duplicate of bug #154142?
Comment 4 Rex Dieter 2005-11-07 15:37:28 EST
Basically, yeah.  Fullfilling this enhancement request will effectively fix bug
#154142.
Comment 5 Daniel Veillard 2006-06-08 09:39:11 EDT
Okay the extra .la should have been removed some time ago, but I forgot.
It should be fixed in rawhide, with the upcoming 1.2.9-7,

Daniel

Note You need to log in before you can comment on or make changes to this bug.