Bug 1714168 - [4.1] Cannot change Requests values in image-registry operator config
Summary: [4.1] Cannot change Requests values in image-registry operator config
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.1.z
Assignee: Ricardo Maraschini
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On: 1726894
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-27 09:52 UTC by Wenjing Zheng
Modified: 2019-08-28 19:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1726894 (view as bug list)
Environment:
Last Closed: 2019-08-28 19:54:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2547 None None None 2019-08-28 19:54:54 UTC
Github openshift cluster-image-registry-operator pull 357 None None None 2019-08-08 07:36:10 UTC

Description Wenjing Zheng 2019-05-27 09:52:28 UTC
Description of problem:
Image-registry pod crashes when change Requests values in image-registry operator config:
  requests:
    read:
      maxInQueue: 2
      maxRunning: 2
      maxWaitInQueue: 100s
    write:
      maxInQueue: 2
      maxRunning: 2
      maxWaitInQueue: 100s

[wzheng@openshift-qe 4.0]$ oc get pods
NAME                                               READY   STATUS             RESTARTS   AGE
cluster-image-registry-operator-66ffb5c976-hsfrl   1/1     Running            0          7h6m
image-registry-6b59656bcc-kps6q                    1/1     Running            0          7h6m
image-registry-7465646c9b-v8wsx                    0/1     CrashLoopBackOff   1          12s
node-ca-26wp5                                      1/1     Running            0          7h6m
node-ca-54j5k                                      1/1     Running            0          7h6m
node-ca-6zrql                                      1/1     Running            0          7h6m
node-ca-mvttv                                      1/1     Running            0          7h6m
node-ca-ww9b2                                      1/1     Running            0          7h6m
[wzheng@openshift-qe 4.0]$ oc logs pods/image-registry-7465646c9b-v8wsx
time="2019-05-27T09:44:16Z" level=fatal msg="error parsing configuration file: yaml: unmarshal errors:\n  line 1: cannot unmarshal !!map into time.Duration"


Version-Release number of selected component (if applicable):
4.1.0-0.nightly-2019-05-24-040103

How reproducible:
Always

Steps to Reproduce:
1.Change request value in image-registry operator config
2.Wait image-registry pod restarts
3.

Actual results:
Pod changes to CrashLoopBackOff.

Expected results:
Pod should be running.

Additional info:

Comment 3 Wenjing Zheng 2019-08-15 05:38:39 UTC
Verified on 4.1.0-0.nightly-2019-08-14-043700.

Comment 6 errata-xmlrpc 2019-08-28 19:54:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2547


Note You need to log in before you can comment on or make changes to this bug.