Bug 171442 - Platforms should be sorted alphabetically
Platforms should be sorted alphabetically
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-21 14:17 EDT by Andrew Overholt
Modified: 2013-06-23 23:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 05:36:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Overholt 2005-10-21 14:17:20 EDT
Description of problem:
While trying to file a bug against powerpc, I noticed that the Platform field is
not sorted.  It is difficult to find powerpc as a result.  It would be nice if
the entries were sorted (even with most common platforms* at the top).

* FC platforms?
Comment 1 David Lawrence 2006-04-08 14:09:20 EDT
Red Hat's current Bugzilla version is 2.18. I am moving all older open bugs to
this version. Any bugs against the older versions will need to be verified that
they are still bugs. This will help me also to sort them better.
Comment 2 Andrew Overholt 2006-06-05 11:52:25 EDT
This is still present.
Comment 3 Ben Konrath 2006-06-05 11:53:48 EDT
Thanks, it's on my radar and I should get to it later this week.
Comment 4 Ben Konrath 2006-06-05 11:58:34 EDT
ooops, I thought this was another bug. Please ignore my last comment :)
Comment 5 David Lawrence 2008-09-16 12:53:49 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 6 Andrew Overholt 2008-10-02 14:01:47 EDT
This is still present.
Comment 7 Noura El hawary 2008-12-01 21:35:22 EST
Basically platforms, op_sys, severity, priority are all ordered by sortkey which is a numerical field in each table that contains those field values, so to sort them alphabetically we either need to change the sortkey numbering to reflect the alphabetical order of the field values, or we can change the sql to order by value rather than order by sortkey which is i think not a very good solution because we are ignoring what the sortkey is for. What do you think Dave?

Noura
Comment 8 David Lawrence 2008-12-02 11:41:05 EST
Yes, I agree that we should not mess with the way the SQL is using the sortkey to sort the results. 

One solution is to run a query on the bugs table and look for the counts of each arch and then order them by popularity.

mysql> select rep_platform, count(rep_platform) from bugs group by rep_platform order by count(rep_platform) desc;
+---------------+---------------------+
| rep_platform  | count(rep_platform) |
+---------------+---------------------+
| All           |              176189 | 
| i386          |               72533 | 
| i686          |               21198 | 
| x86_64        |               12828 | 
| ia64          |                4543 | 
| powerpc       |                2556 | 
| athlon        |                2471 | 
| i586          |                1999 | 
| s390x         |                1169 | 
| alpha         |                1143 | 
| ppc64         |                 972 | 
| s390          |                 917 | 
| other         |                 758 | 
| sparc         |                 497 | 
| noarch        |                 422 | 
| ia32e         |                 175 | 
| sparc64       |                  52 | 
| sh4           |                  35 | 
| sparcv9       |                  28 | 
| arm9          |                  22 | 
| parisc11      |                  21 | 
| xscale        |                  14 | 
| alphaev6      |                  14 | 
| strongarm     |                  10 | 
| arm7          |                  10 | 
| ppc           |                   9 | 
| mips32        |                   6 | 
| sparclite     |                   4 | 
| synth         |                   3 | 
| sh3           |                   3 | 
| mips64        |                   3 | 
| mipstx39      |                   3 | 
| mipsnecvr4xxx |                   2 | 
| mipstx49      |                   2 | 
| mipsrm7000    |                   2 | 
| v850          |                   1 | 
+---------------+---------------------+
36 rows in set (0.20 sec)

Andrew, would you be fine with ordering it this way?

Dave
Comment 9 Andrew Overholt 2008-12-02 11:50:11 EST
I guess.  I still think alphabetic is better for consistency but this is better than the current ordering and maybe I'm just weird in that I look for things in alphabetic ordering by default :)
Comment 10 Noura El hawary 2008-12-03 05:36:24 EST
Hey Dave,

I have ordered the rep_platform values according to popularity as you suggested and agreed with Andrew, for values with same popularity i ordered them alphabetically:

select rep_platform, count(rep_platform) from bugs group by rep_platform order by count(rep_platform) desc, rep_platform asc;

it should show now in live bugzilla

Noura
Comment 11 Andrew Overholt 2008-12-03 08:44:17 EST
Thanks!

Note You need to log in before you can comment on or make changes to this bug.