Bug 1714501 - Octavia tempest test test_provider_list fails
Summary: Octavia tempest test test_provider_list fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: beta
: 15.0 (Stein)
Assignee: Carlos Goncalves
QA Contact: Bruna Bonguardo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-28 09:16 UTC by Carlos Goncalves
Modified: 2019-09-26 10:51 UTC (History)
4 users (show)

Fixed In Version: puppet-tripleo-10.4.2-0.20190623230404.53b3156.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:22:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1830702 0 None None None 2019-05-28 09:18:19 UTC
OpenStack gerrit 661703 0 None None None 2019-05-28 09:18:19 UTC
OpenStack gerrit 661842 0 None None None 2019-05-28 21:02:18 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:22:49 UTC

Description Carlos Goncalves 2019-05-28 09:16:54 UTC
Description of problem:

When running Octavia tempest tests on a TripleO Stein deployment, test octavia_tempest_plugin.tests.api.v2.test_provider.ProviderAPITest.test_provider_list fails.


Version-Release number of selected component (if applicable):
RHOS_TRUNK-15.0-RHEL-8-20190523.n.1

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP 15 with Octavia enabled
2. Run Tempest test octavia_tempest_plugin.tests.api.v2.test_provider.ProviderAPITest.test_provider_list

Actual results:

ft4.1: octavia_tempest_plugin.tests.api.v2.test_provider.ProviderAPITest.test_provider_list[id-8b94e0cc-a24d-4c29-bc8e-53f58214dc67]testtools.testresult.real._StringException: pythonlogging:'': {{{
2019-05-27 15:50:17,924 310905 INFO [tempest.lib.common.rest_client] Request (ProviderAPITest:test_provider_list): 200 GET http://10.0.0.116:9876/v2.0/lbaas/providers 0.349s
2019-05-27 15:50:17,924 310905 DEBUG [tempest.lib.common.rest_client] Request - Headers: {'Content-Type': 'application/json', 'Accept': 'application/json', 'X-Auth-Token': '<omitted>'}
        Body: None
    Response - Headers: {'date': 'Mon, 27 May 2019 19:50:17 GMT', 'server': 'Apache', 'content-length': '220', 'x-openstack-request-id': 'req-58b949eb-35ad-4a7b-a1f8-dd665731921c', 'vary': 'Accept-Encoding', 'connection': 'close', 'content-type': 'application/json', 'status': '200', 'content-location': 'http://10.0.0.116:9876/v2.0/lbaas/providers'}
        Body: b'{"providers": [{"name": "amphora", "description": "Octavia Amphora Driver."}, {"name": "octavia", "description": "Deprecated alias of the Octavia Amphora driver."}, {"name": "ovn", "description": "Octavia OVN driver."}]}'
}}}

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/octavia_tempest_plugin/tests/api/v2/test_provider.py", line 58, in test_provider_list
    provider.get(const.DESCRIPTION, ''))
  File "/usr/lib/python3.6/site-packages/testtools/testcase.py", line 411, in assertEqual
    self.assertThat(observed, matcher, message)
  File "/usr/lib/python3.6/site-packages/testtools/testcase.py", line 498, in assertThat
    raise mismatch_error
testtools.matchers._impl.MismatchError: 'The Octavia Amphora driver.' != 'Octavia Amphora Driver.'

Expected results:

Test would succeed.

Comment 7 errata-xmlrpc 2019-09-21 11:22:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.