Bug 1714897 - The initial status on dc detail page is not correct
Summary: The initial status on dc detail page is not correct
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.2.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-29 06:42 UTC by Yanping Zhang
Modified: 2019-10-16 06:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the deployment config details page in the web console would say the status is "Active" before the first revision had rolled out. The status now says "Updating" before a rollout has occurred and "Up to date" when the rollout is complete.
Clone Of:
Environment:
Last Closed: 2019-10-16 06:29:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:29:43 UTC

Description Yanping Zhang 2019-05-29 06:42:31 UTC
Description of problem:
When create a dc from yaml on dc page, check on the dc detail page, the "STATUS" field showes "Active" first, then becomes "Updating",and finally "Active" again

Version-Release number of selected component (if applicable):
4.1.0-0.nightly-2019-05-24-040103
console image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:e6b3e376fd5e0e69d65d12f75e349691e21b155b196618dcbfc3cd9865c343cf
commit:
https://github.com/openshift/console/commit/d8fc460a3d0e9f8de3d14373de8f36ba09103537
How reproducible:
Always

Steps to Reproduce:
1.Create dc from yaml in project on console. check the "STATUS" field on dc detail page.
2. 
3.

Actual results:
1.It showes "Active" first, then becomes "Updating" and finally "Active" again
2. Watch DC status in CLI
Pending -> Running -> Complete

Expected results:
1. Should not show "Active" when DC is just created since it doesn't start to rollout.

Additional info:

Comment 1 Samuel Padgett 2019-05-29 13:25:27 UTC
https://github.com/openshift/console/pull/1624

Comment 3 Yanping Zhang 2019-06-26 03:40:31 UTC
build: 4.2.0-0.nightly-2019-06-24-160709
console commit: 54fb3ee81a277b313798da833560acd6cb280790
Checked on ocp 4.2 env with above version. 
Created dc, checked status on dc detail page. It showed "Updating" when rolling out, after completed, it showed "Up to date".
The status is correct. Move the bug to Verified.

Comment 5 errata-xmlrpc 2019-10-16 06:29:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.