Bug 171503 - omit /usr/lib/lib*.la
Summary: omit /usr/lib/lib*.la
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: digikam   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marcin Garski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-21 21:24 UTC by Rex Dieter
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 0.7.4-4
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-22 20:34:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rex Dieter 2005-10-21 21:24:01 UTC
You can safely omit packaging those pesky libtool archives from
/usr/lib/lib*.la

Comment 1 Rex Dieter 2005-10-21 21:24:58 UTC
BTW, were you intending on submitting digikamimageplugins and/or kipi-plugins? 
If not, I can submit them soon for review.

Comment 2 Rex Dieter 2005-10-22 16:46:30 UTC
FYI, 

kipi-plugins reviewed and imported into cvs.

digikamimageplugins is submitted and under review, but is blocking on this bug .
See bug #171505.

Comment 3 Marcin Garski 2005-10-22 19:21:09 UTC
I'm not intending on submitting digikamimageplugins or kipi-plugins.

Is excluding .la files realy safe, I'm asking because of bug #165616 Comment #16
and Comment #17, also https://bugs.kde.org/show_bug.cgi?id=93359

"It has been noticed that Imlib2, a library which uses libtool's API for loading
plugins at run-time, fails in Digikam 0.7"

"When called from within Digikam, which is a KDE application and linked against
libkdecore, Imlib2's plugin loader fails to
find its *.so files, because the libltdl included with KDE is not built with
support for .so files."

Comment 4 Rex Dieter 2005-10-22 19:26:02 UTC
digikam's inclusion of /usr/lib/lib*.la files (or not) has nothing to with that
other kdelibs bug.  In short, they're safe to remove (or I wouldn't have asked
for it).  (-:

Comment 5 Rex Dieter 2005-10-22 19:39:44 UTC
More precisely, libtool archives for shared libraries, ie, those matching
%_libdir/lib*.so
are usually superfluous and can safely be removed.

libtool archives for loadable modules, ie, those matching
%_libdir/kde/*.so
*sometimes* need their .la counterparts (especially when the aforementioned
kdelibs bug hasn't been fixed, see also bug #171544


Comment 6 Marcin Garski 2005-10-22 20:34:57 UTC
Exclude libdigikam.la, packages will appear soon.


Note You need to log in before you can comment on or make changes to this bug.