Bug 171521 - NFS client reporting server not responding errors when mounted to lvm2 logical volume on top of md multipath device
NFS client reporting server not responding errors when mounted to lvm2 logica...
Status: CLOSED DUPLICATE of bug 171520
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mdadm (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Depends On:
  Show dependency treegraph
Reported: 2005-10-21 21:39 EDT by Henry Harris
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-10-21 21:41:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Henry Harris 2005-10-21 21:39:56 EDT
Description of problem: An NFS client mounting either a GFS file system or an 
ext3 file system sitting on top of an lvm2 logical volume on top of a 
multipath md device on an NFS server getting occassional "server not 
responding" errors.

Version-Release number of selected component (if applicable): RHEL4 U2

How reproducible:
Every time

Steps to Reproduce:
1. Create an multipath md device with one LUN
2. Create an LVM2 logical volume
3. Format with either GFS or ext3
4. Export via NFS
5. Create script to continuously copy large file to NFS mount on client
Actual results:
NFS client reports server not responding several times over a 10 minute period

Expected results:
NFS client does not report errors

Additional info:
This has been seen on multiple clusters with GFS.  The NFS server (running 
GFS/Cluster Manager) sometimes reports nfsd: non-standard errno -38 when the 
NFS client gets this error.  Sometimes it does not.  I tried exactly the same 
test with the same NFS client and an ext3 volume on an internal drive on the 
same NFS server without a problem.  I have tried to reproduce this on sd 
devices to be sure that the md driver is causing the problem but I am having 
problems creating another volume group on the same cluster with sd devices.  I 
will write a separate bug on this issue.  I have however seen this on multiple 
GFS clusters with multiple NFS clients, but all are using md multipath devices 
under LVM2.
Comment 1 Henry Harris 2005-10-21 21:41:58 EDT

*** This bug has been marked as a duplicate of 171520 ***

Note You need to log in before you can comment on or make changes to this bug.