Bug 171523 - check-update should prompt user for update
check-update should prompt user for update
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-22 02:40 EDT by Christopher Stone
Modified: 2014-01-21 17:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-22 18:17:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Stone 2005-10-22 02:40:46 EDT
Description of problem:
Almost on a daily basis (i run update a lot), yum check-update will report new
packages, however when I run yum update it reports that there are not packages
avialable for updating.  This ofcourse is due to mirrors being out of sync.

My solution to this problem is simple.  Have yum prompt the user after running
check-update if she wants to update packages immediately (if there are packages
available for updating).  yum would then use the same mirrors it used during the
check to run the update.

Not only does this solution prevent having to run the extra step for the user to
run yum update, it also will use the same mirrors as the check-update used and
the user will not run into the problem of scanning other mirrors during the next
run which may not be in sync.

Version-Release number of selected component (if applicable):
yum-2.4.0-0.fc4

How reproducible:
yum check-update (using mirrors that have been updated)
yum update (using different mirrors that are not updated yet)

Steps to Reproduce:
1.  yum check-update
2.  yum update
  
Actual results:
yum check-update reports that packages are available for upgrading
yum update then reports no packages avialable for updating because it used
different mirrors which havn't been updated yet.


Expected results:
yum check-update prompts user if she wants to update packages after running the
check if packages are available for updating, and yum would then use the same
mirrors it used when performing the check.

Additional info:
This method is more user friendly as well.
Comment 1 Seth Vidal 2005-10-22 09:30:35 EDT
easier yet:

yum shell
> list updates
> update
> run

that's it

your mirrors won't change inside the shell.
Comment 2 Christopher Stone 2005-10-22 16:06:42 EDT
It's nice to know this work-around, but it's not a fix for the bug I reported. 
Please mark this bug as WONTFIX instead of WORKSFORME.

I like my solution better for two reasons:

1) I only have to run one single command instead of four commands
2) It's more user/newbie friendly
Comment 3 Seth Vidal 2005-10-22 18:16:43 EDT
yum shell takes a filename as an optional argument

put:
list updates
update
run

in a file

then run:
yum shell thatfile

then it's one command

Note You need to log in before you can comment on or make changes to this bug.